Virtualmin is configured to setup DNS zones, but this system is not setup to use itself as a DNS server.

Hmm, sorry for creating another thread, but thought this deserves its own thread. This question was asked few times in this forum, but i was unable to find a clear answer that i would follow. So it would be awesome if someone can give me a quick fix for this (would help everyone else too)…

Any way, i was trying to run “Re-Check Config” under “System Settings” and i get the following:

Virtualmin is configured to setup DNS zones, but this system is not setup to use itself as a DNS server. Either add to the list of DNS servers, or turn off the BIND feature on the module config page.

… your system is not ready for use by Virtualmin.

any idea how to Fix this?

Im running CentOS 5.5 on a VPS hosted by volume drive (if that helps).
Just to add, im really noob, so it would be greatly appreciated if you can explain a tiny bit in detail what i can/should do… :slight_smile:

Thanks in advance.

1 Like

just to add,

i can simply add to the list of DNS servers (this fixes the problem)… but sadly, when ever i restart my vps, the list of dns servers resets back to default and i get this same error again… so i guess every time i restart my server i can remember to add this again, but is there any way to fix this (or prevent this from happening)? O.o

1 Like

Chances are that’s happening due to your IP address being obtained by DHCP. By default, the DHCP client will set a number of things, including the DNS servers.

To prevent that, edit /etc/dhclient-eth0.conf , and make sure there is a line like :

prepend domain-name-servers;

hmmmm, cant seem to find that file… any other ideas? or should i create that file instead?

here is a ls of my etc folder (if it helps)…

[root@bob ~]# cd /etc [root@bob etc]# ls adjtime rc2.d aliases rc3.d aliases.db libaudit.conf rc4.d alternatives libuser.conf rc5.d awstats localtime rc6.d bashrc login.defs rc.d blkid logrotate.conf rc.local clamd.d logrotate.d rc.sysinit cron.d lvm redhat-release cron.daily mail resolv.conf cron.deny mailcap rndc.key cron.hourly mailman rpc cron.monthly mail.rc rpm crontab makedev.d rwtab cron.weekly mime.types rwtab.d csh.cshrc mke2fs.conf sasl2 csh.login modprobe.d scsi_id.config db.cache motd securetty dbus-1 mtab security default multipath.conf selinux depmod.d my.cnf sensors.conf dev.d named.caching-nameserver.conf services DIR_COLORS named.conf sestatus.conf DIR_COLORS.xterm named.rfc1912.zones setuptool.d dovecot.conf netplug shadow environment netplug.d shadow- exports nsswitch.conf shells fedora odbc.ini skel filesystems odbcinst.ini smrsh fonts openldap snmp freshclam.conf opt ssh fstab pam.d subversion ftpusers passwd sudoers gcrypt passwd- sysconfig group pear.conf sysctl.conf group- php.d syslog.conf host.conf php.ini termcap HOSTNAME pki udev hosts postfix usermin hosts.allow ppp vimrc hosts.deny printcap virc httpd procmailrc virtualmin-license init.d profile warnquota.conf initlog.conf profile.d webalizer.conf inittab proftpd.conf webmin inputrc protocols wgetrc iproute2 quotagrpadmins X11 issue quotatab xinetd.d rc yum krb5.conf rc0.d yum.conf rc1.d yum.repos.d
1 Like

Do you have a file “/etc/sysconfig/network-scripts/ifcfg-eth0”? If so, what are it’s contents?


no such file again…

here are the content of the network script folder:

[root@bob network-scripts]# ls
ifcfg-lo ifdown-isdn ifup-eth ifup-routes
ifcfg-venet0 ifdown-post ifup-ippp ifup-sit
ifcfg-venet0:0 ifdown-ppp ifup-ipsec ifup-sl
ifcfg-venet0:1 ifdown-routes ifup-ipv6 ifup-tunnel
ifdown ifdown-sit ifup-ipx ifup-wireless
ifdown-bnep ifdown-sl ifup-isdn init.ipv6-global
ifdown-eth ifdown-tunnel ifup-plip net.hotplug
ifdown-ippp ifup ifup-plusb network-functions
ifdown-ipsec ifup-aliases ifup-post network-functions-ipv6
ifdown-ipv6 ifup-bnep ifup-ppp route-venet0

1 Like

I’m facing the exact same error.

Virtualmin is configured to setup DNS zones, but this system is not setup to use itself as a DNS server. Either add to the list of DNS servers, or turn off the BIND feature on the module config page.

I add and then when you restart, the same thing again.

@daysonp: I suppose the same question which remained unanswered a few months back also applies to you: Is your system getting its IP address via DHCP?

This link might help:

haha yeah, i never found a solution to this… have to manually set the every time i restart… siigh, its annoying… Any idea what will happen if i ever forget this?

and thanks Locutus, will have a look at that link later, see if it helps me at all…

I see this is an old thread, but maybe someone else searching could make some use from it.

To fix the issue relating to not staying after a reboot or when ever.

I did this on a desktop version of ubuntu.
open the network connections icon, then highlight your network interface. now click edit to that interface.
I am assuming the IP has been setup static and you are behind a router.
Look at the DNS section, and add
You may need to find out what your DNS ip’s are. (You can do this be looking in your router.)

here is an example of how mine DNS setting look in my settings.

DNS: 123.456.789.1, 987.654.321.1,

I wonder, does it even matter if is not listed. Doesn’t it just mean that lookups will be done remotely instead of locally?

If someone knows what is the counterpart for the shell (I doubt if much people use a desktop on their server) for the desktop solution on CentOS 6 or Scientific Linux 6 then please let us know.

The IP has to be listed in /etc/resolv.conf if your domains are configured to use your local server as their nameserver.

If that IP isn’t listed, then lookups of your domains won’t work properly.

If, OTOH, your server isn’t acting as a nameserver for your domains you can just uncheck the BIND DNS Domain feature.


I can’t believe that this is still happening on my CentOS 6.5. And no, my IPs are not assigned by DHCP. I tried manually entering the IP into /etc/resolv.conf but it only stays there until server reboots.

Are you by chance on a VPS, perhaps OpenVZ? Or do you have a dedicated server?


I have a dedicated server. I installed CentOS 6.5 64-bit by myself.

Are you by chance on a VPS, perhaps OpenVZ? Or do you have a dedicated server?

I can confirm that I recently saw the same thing when setting up virtualmin inside a OpenVZ container (CentOS) on a Debian 7/Wheezy HW node.

Okay, what output do you receive if you run this command:


The OpenVZ container (running CentOS 6/64 bit) is up and running with lo/venet0/venet0:0 interfaces and a public IP - but there are no entries under /etc/sysconfig/networking/devices/

Note that the OpenVZ container was set up by and is running via Proxmox.

And it’s not a real issue here, I just added the entry and everything works nicely.

When I run:


I get “Permission denied” message.

Try doing that as the root user.