Virtualmin installs but I get an suexec error

I installed virtualmin to a system with an existing webmin setup from Webmin Modules > Install > From ftp or http URL:
The following modules have been successfully installed and added to your access control list :
Virtualmin Virtual Servers (GPL) in /usr/local/lib/webmin/virtual-server (4020 kB) under category Servers

When I browse to my.domain/virtual-server I get
Virtualmin’s configuration has not been checked since it was last updated. Click the button below to verify it now.

Upon Clicking the button I get:
The status of your system is being checked to ensure that all enabled features are available, that the mail server is properly configured, and that quotas are active …
BIND DNS server is installed, and the system is configured to use it.
Mail server Sendmail is installed and configured.
Suexec is enabled in the default template, but the Apache module mod_suexec is not installed or not enabled.
… your system is not ready for use by Virtualmin.

OS is FreeBSD 6.3

When I start Apache I get the following in httpd-error.log
[Tue Jun 10 11:09:21 2008] [notice] suEXEC mechanism enabled (wrapper: /usr/local/sbin/suexec)
[Tue Jun 10 11:09:22 2008] [notice] Digest: generating secret for digest authentication …
[Tue Jun 10 11:09:22 2008] [notice] Digest: done
[Tue Jun 10 11:09:23 2008] [notice] Apache/2.2.8 (FreeBSD) mod_ssl/2.2.8 OpenSSL/0.9.8g DAV/2 PHP/5.2.6 with Suhosin-Patch configured – resuming normal operation

Clearly suexec is installed and enabled!!!

What have I missed/done incorrectly???

Make sure that mod_suexec is being loaded in apache. You can check this by going to Webmin -> Servers -> Apache -> Global Settings -> modules

Got it figured out.

Web min was finding my configs for apache 1.3 but I had upgraded to Apache 2.2 so webmin was looking at the config files for 1.3 NOT 2.2.

As soon as I changed the apache config file to /usr/local/etc/apache22/httpd.conf it started working.

I have the same problem, but I use virtualmin GPL and Ubuntu 6.06.
The suexec module is enabled in apache. I think the apache is configured wrong but I don’t know how to fix it.
Found a similar subject somewhere telling that apache is looking for suexec in other directory (or the otherwise), but it didn’t had a resolution.
If that’s the problem, can someone help me to fix it, please? In noob terms.
Thank you~!

For clarifications sake, can you paste in the exact problem/errors you’re seeing?

Also, if you log in over SSH and type this command, what output do you get:

dpkg -l ‘apache*’


I’ve meesed up mine, meanwhile. Tried to uninstall it and reinstall it again.
Using your command, now I got:

Desired=Unknown/Install/Remove/Purge/Hold | Status=Not/Installed/Config-f/Unpacked/Failed-cfg/Half-inst/t-aWait/T-pend |/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad) ||/ Name Version Description +++-==============-==============-============================================ rc apache 1.3.34-4.1+etc versatile, high-performance HTTP server un apache-common <none> (no description available) un apache-doc <none> (no description available) un apache-modules <none> (no description available) un apache-utils <none> (no description available) ii apache2 2.0.55-4ubuntu next generation, scalable, extendable web se rc apache2-common 2.0.55-4ubuntu next generation, scalable, extendable web se un apache2-doc <none> (no description available) un apache2-mpm <none> (no description available) un apache2-mpm-it <none> (no description available) un apache2-mpm-pe <none> (no description available) pn apache2-mpm-pr <none> (no description available) un apache2-mpm-wo <none> (no description available) ii apache2-suexec 2.2.9-7ubuntu3 Standard suexec program for Apache 2 mod_sue ii apache2-utils 2.2.8-1ubuntu0 utility programs for webservers in apache2.2-comm <none> (no description available)

So now, in webmin under the servers I can’t see apache, but in software package see it says those 3 are installed: apache2 2.0.55-4ubuntu2.3, apache2-suexec 2.2.9-7ubuntu3, apache2-utils 2.2.8-1ubuntu0.3
I’ve also reinstalled postfix from, worked fine but virtualmin doesn’t seem to know where it is, cause it gives me an error page when trying to open the postfix configuration link.
hink everything is messed up. Now I’m lost and actually thinking to pay someone to configure my server.

Okay, I think there’s a few issues at work here.

It looks like you have the Ubuntu Apache packages installed – that won’t work unfortunately, Virtualmin provides it’s own Apache packages.

However, I think the problem is that you have Ubuntu 6.06 – the GPL version of Virtualmin doesn’t support that or provide packages for it.

So, you probably aren’t going to have much luck using Virtualmin on Ubuntu 6.06 unless you were to upgrade to Virtualmin Pro.

The GPL version does support Ubuntu 8.04, so one option would be to upgrade your distribution.

You can see the supported distros here – the ones supported by Virtualmin Pro are at the top, the GPL distros are at the bottom:

I see.
I didn’t knew that. Well, I’m also trying to upgrade the Ubuntu, but that’s another story, for the Ubuntu’s forum :slight_smile:
Thanks for you advice!

I wanted to just chime in and clarify about compatibility.

Virtualmin (GPL and Professional) is compatible with a vast array of operating systems, including many that are not listed on the OS support page.

The installer, and our packages for a full stack, are only available for the specific systems mentioned. If you want easy to install, easy to configure, and works without hassle, you’ll want to use one of those systems. If you are a seriously hardcore UNIX nerd, you can use any OS you like (even some that have never run Virtualmin before–making it work on other systems supported by Webmin is generally trivial, if you can handle the manual installation and configuration…Windows being the obvious exception, where Virtualmin will not work at all, and probably won’t any time in the near future, because of fundamental differences).

Anyway, I always recommend folks use a supported OS and use the automated installation process on a freshly installed OS. It just makes your life dramatically easier. But, if you’re already on a production system…you don’t really have that option. :wink:

I appear to be having the same problem here. I am however using the commercial version of Virtualmin, and using Ubuntu Dapper. The following is the output I get from:

[code:1]dpkg -l ‘apache*’
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
pn apache <none> (no description available)
rc apache-common 1.3.34-2 support files for all Apache webservers
un apache-doc <none> (no description available)
un apache-modules <none> (no description available)
un apache-perl <none> (no description available)
un apache-ssl <none> (no description available)
un apache-utils <none> (no description available)
pn apache2 <none> (no description available)
ii apache2-common 2.0.55-5vm2.1 next generation, scalable, extendable web server
ii apache2-doc 2.0.55-5vm2.1 documentation for apache2
un apache2-modules <none> (no description available)
un apache2-mpm-perchild <none> (no description available)
ii apache2-mpm-prefork 2.0.55-5vm2.1 traditional model for Apache2
un apache2-mpm-threadpoo <none> (no description available)
un apache2-mpm-worker <none> (no description available)
ii apache2-utils 2.0.55-5vm2.1 utility programs for webservers[/code:1]

I don’t see the apache2-suexec in there. Any ideas?