Virtualmin installed on a VPS - having ip allocation problems


I have installed virtualmin gpl onto a virtual server. I have added my 2 ip addresses into the defalt server template for allocation (attached image point 1).

When I try to add a domain (create virtual server) I have the choice of Network interface - “shared on” or “virtual with allocated ip” (attached image point 2). when I select “virtual with allocated ip” I get error message (attached image point 3).

My network interface settings look like - attached image network-interface.png

Any help appreciated.


Hi Andy,

You would only want to use the “Virtual” IP address allocation if that particular IP address is not in use already for another domain… you would use that when the IP address is intended to be dedicated for a particular domain. That comes up for things like SSL.

Are you by chance using that IP for other domains now? If so, that would explain the error you’re seeing there.


I have been given 2 ip addresses, i want to add a domain and use a SSL that why i was trying to choose the second ip that i allocated in server template. Thats why i tried “virtual with allocated ip” instead of the default “shared ip”

here is some details they gave me:

because they allocated them as nameserver ip’s does this mean i cannot do that?

My suggestion for getting that to work would be to not list the second IP in the “Range for automatic IP allocation” in the Server Templates.

Keep the first IP shared (as it is by default), and use that for all your domains; and keep the second IP private, and use it for that one domain for SSL.


I have done that and it appears to have worked…