Virtualmin Installation Error, Please Assist

I found an error in the installation, I do not understand what this represents, how to solve this problem? Please help me, thank you~

/usr/sbin/setenforce: SELinux is disabled
–2018-05-07 03:37:40--
Connecting to||:80… connected.
HTTP request sent, awaiting response… 200 OK
Length: 31123 (30K) [application/x-sh]
Saving to: “”

100%[======================================>] 31,123 --.-K/s in 0.1s

2018-05-07 03:37:40 (207 KB/s) - “” saved [31123/31123]

chmod: cannot access `’: No such file or directory line 288: ./ No such file or directory
***** virtualmin install Failed *****

I only intercepted part of the text and ended up in the wrong place


How did you if you did solve this? I have the same error with the addition of - the certificate of is not trusted and has not got a know issuer


Sorted, for some reason a clean install of debian 8 is not installing the ca certs on clean install, to get round this apt-get install ca-certificates


I have solved the problem and my system is centos 7,
Execute yum update -y
Improve all system installation packages

I did the yum update -y but nothing is working. I even tried the purchased version Virtualmin and that didn’t fix it. I tried a new DO Ubuntu droplet and that didn’t work either.

I have solved my problem by adding nameservers on /etc/resolv.conf you might be installing on a new system without dns servers

I know this is an old thread, but here goes my 2 cents.
The problem just happened to me, and it was because I was installing Virtualmin on an old server. Check the date on the system, if your date/time is wrong you’ll get certificate errors. My date was a few years off, hehe. Updated it with ntp, and the installation went smoothly.

Hello everyone

I have the same error with script for install and uninstall :

wget: unable to resolve host address ‘
chmod: cannot access ‘’: No such file or directory 288: .: Can’t open ./

any recommendation will be appreciated