Virtualmin Install Script Error - CentOS 6.3 x86_64 (net install)

Hi fellow Virtualmin operators,

Recently I installed a clean copy of CentOS 6.3 x86_64 to a web server running on aurora.seven-labs.com and keep receiving a halt in the virtualmin installation script.


FATAL - 2012-08-01 07:46:51 - Fatal Error Occurred: Something went wrong during installation: 0
FATAL - 2012-08-01 07:46:51 - Cannot continue installation.


I believe this is one of the supported operating systems and the error is somewhat confusing/vague.

Output from installation script:

The systems currently supported by install.sh are:
CentOS and RHEL 5-6 on i386 and x86_64
Scientific Linux 6 on i386 and x86_64
Debian 6.0 on i386 and amd64
Ubuntu 8.04 LTS and 10.04 LTS, and 12.04 LTS on i386 and amd64
Amazon Linux 2012.03 on i386 and x86_64
FreeBSD 7.0 and 8 on i386 and amd64


I attached my entire virtualmin-install.log file for reference.

My question is has anyone had this same issue or know how to resolve? I've done some googling to no success.

Thanks in advance for any answers/solutions/ideas you may have.

SE7EN (Sam) 
Seven-Labs
Eclipse Developer

Well I’ve resolved this problem after reviewing the log file further.

Turns out it was httpd-manual causing the entire problem.

I ran the following
rpm -e httpd-manual
to remove the package

then executed with
/bin/sh ./install.sh

To retry the installation (thinking this would be resolved by reinstalling httpd-manual with the installer script. Turns out it worked flawlessly, and now I just have to configure the server and should be done.

Thanks for viewing the post though, and to Virtualmin devs, thanks for the great administration tool, I’ve used many others but prefer this one over CPanel and Plesk.

I’m glad you figured it out, thanks for letting us know how you got it working!

-Eric

Hi all, new user here.

Just wanted to let you know I got the exact same problem on a fresh Centos 6.3 install and resolved it the exact same way.

Thanks for posting the solution!

You are quite welcome glad this helped, sorry to bring back an old post, just saw this reply. I haven’t received this error since the newer virtualmin updates were released. Although I’ve also learned to update server before installing Virtualmin.

SE7EN
http://www.seven-labs.com