Virtualmin install: php stops working after server reboot

a brand new installation of ubuntu 14.04, nothing else is installed.

i install virtualmin using their install script.

i upload info.php, test it, i get the info page, php works fine.

i reboot the server. php no longer works. the page is found but nothing displays, it’s as if php is not installed, even though it is.

i reinstall the OS, install php5 by itself, it works fine, no issue after reboot.

i can’t imagine i’m doing something wrong, i just ran the script.

does anybody know how to fix this or have some suggestions on how i can begin to trouble shoot the problem?
i have error reporting turned on. there is no error. in firefox nothing appears, in opera the code itself displays.

the problem is not the white screen of death.

any help is appreciated.


Hmm, does it work to upload a .html file? Is that displayed properly, even when .php files aren’t working for you?

Also, do you notice any errors in the error logs located in $HOME/logs/error_log?


yes an html page works. this is the site and then does not work.

before i rebooted info.php worked, it brought up the php info in the browser. and my index.php
which uses php code to call code from another php file worked.
after reboot, html still works. but php is handled as if it were plain text in opera,
and in my old version of FF i get just a blank page but the page source shows the php code is there.

it doesn’t seem to make any sense to me why it would work upon install but not after reboot.
the only thing i can imagine is something isn’t being started back up after shutdown.

i previously installed webmin and virtualmin separately without using the install script on a different VPS and didn’t encounter this issue. so i’m baffled, but i really have to solve this or else virtualmin is useless for me, it kind of blows my plans up.

this is some stuff i found in the error log. i’m not sure if it’s before or after the reboot or both.
plus i did some fiddling to try to get it to work so maybe that might have thrown some stuff in the log.

[mpm_prefork:notice] [pid 21262] AH00163: Apache/2.4.7 (Ubuntu) SVN/1.8.8 mod_fcgid/2.3.9 PHP/5.5.9-1ubuntu4.5 configured -- resuming normal operations [core:notice] [pid 21262] AH00094: Command line: '/usr/sbin/apache2' [mpm_prefork:notice] [pid 21262] AH00169: caught SIGTERM, shutting down [mpm_prefork:notice] [pid 21342] AH00163: Apache/2.4.7 (Ubuntu) SVN/1.8.8 mod_fcgid/2.3.9 PHP/5.5.9-1ubuntu4.5 configured -- resuming normal operations [core:notice] [pid 21342] AH00094: Command line: '/usr/sbin/apache2' [mpm_prefork:notice] [pid 21342] AH00171: Graceful restart requested, doing restart [mpm_prefork:notice] [pid 21342] AH00163: Apache/2.4.7 (Ubuntu) SVN/1 [suexec:notice] [pid 1491] AH01232: suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec) [auth_digest:notice] [pid 1492] AH01757: generating secret for digest authentication ... [mpm_prefork:notice] [pid 1492] AH00163: Apache/2.4.7 (Ubuntu) SVN/1.8.8 mod_fcgid/2.3.9 PHP/5.5.9-1ubuntu4.5 OpenSSL/1.0.1f configured -- resuming normal operations [core:notice] [pid 1492] AH00094: Command line: '/usr/sbin/apache2' [mpm_prefork:notice] [pid 1492] AH00169: caught SIGTERM, shutting down [suexec:notice] [pid 2074] AH01232: suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec) [auth_digest:notice] [pid 2075] AH01757: generating secret for digest authentication ... [mpm_prefork:notice] [pid 2075] AH00163: Apache/2.4.7 (Ubuntu) SVN/1.8.8 mod_fcgid/2.3.9 PHP/5.5.9-1ubuntu4.5 OpenSSL/1.0.1f configured -- resuming normal operations [core:notice] [pid 2075] AH00094: Command line: '/usr/sbin/apache2'


Hmm, I don’t see any related errors in those logs, but those look like your system log files, in /var/log/apache2.

Do you see any error’s in the domain’s error log, which is located in $HOME/logs/error_log?

Also, if you go into System Settings -> Re-Check Config, does it detect any problems there?


hi eric, can you tell me how to get to $HOME/logs/error_log? i log into the server using WinSCP as root, but i don’t have the $home directory. i’m on a shared VPS. i googled it, some people said where that log is depends on where the webhost company decides to put it, maybe it’s in /var/log/apache2, which is what i posted. if not then i have to contact the webhost and ask them.
does that sound right to you?

i did the re-check thing several times. the first time, i got two errors, postfix couldn’t find a hostname or something, i entered “localhost”. that cleared that up. then i got a mailman error and i disabled mailman per an old post of yours i found. the last time i reinstalled virtualmin and did recheck, i got
“Virtualmin is configured to setup DNS zones, but this system is not setup to use itself as a DNS server. Either add to the list of DNS servers, or turn off the BIND feature on the module config page.”
which i haven’t done anything about. those were the only errors i got.


The “$HOME” notation is a variable that refers to the home directory of that particular domain.

The log location is normally something like “/home/VIRTUAL-SERVER-OWNER/logs”.


hi, i’m still trying to find the error_log file. i’ve searched in every directory. i will keep trying.
in the meantime i suddenly started to get a “untrusted connection” error from my browser from within virtualmin’s panel. in any case i started clean again and reinstalled virtualmin again.
these are some errors and info i got during the installation from the shell screen.
could the last one, about quotes and having to reboot, have something to do with it?

INFO - Removing Debian apache packages…
dpkg: warning: while removing apache2, directory ‘/var/www/html’ not empty so not removed

Configuring mailman for domain localhost.localdomain …
.Upgrading from version 0x0 to 0x20110f0
getting rid of old source files
update-rc.d: warning: default stop runlevel arguments (0 1 6) do not match mailman Default-Stop values (none)

  • Site list for mailman missing (looking for list named ‘mailman’).
  • Please create it; until then, mailman will refuse to start.

Warning: The home dir /var/run/proftpd you specified can’t be accessed: No such file or directory
Adding system user proftpd' (UID 113) ... Adding new user proftpd’ (UID 113) with group nogroup' ... Not creating home directory /var/run/proftpd’.
Adding system user ftp' (UID 114) ... Adding new user ftp’ (UID 114) with group nogroup' ... Creating home directory /srv/ftp’ …
‘/usr/share/proftpd/templates/welcome.msg’ -> ‘/srv/ftp/welcome.msg.proftpd-new’

  • Starting ftp server proftpd

Enabling quotas on filesystem for /home
The filesystem / could not be remounted with quotas enabled. You may need to reboot your system, and then enable quotas in the Disk Quotas module.

ok, so i restalled everything and the same result.
this is a list of system logs from webmin’s interface. i don;t see error_log.
does this mean i should ask my provider about it?

System Logs Search Docs…

Add a new system log.
Log destination Active? Messages selected
File /var/log/auth.log Yes auth,authpriv.* View…
File /var/log/syslog Yes . ; auth,authpriv.none View…
File /var/log/cron.log No cron.*
File /var/log/daemon.log No daemon.*
File /var/log/kern.log Yes kern.* View…
File /var/log/lpr.log No lpr.*
File /var/log/mail.log Yes mail.* View…
File /var/log/user.log No user.*
File /var/log/ No
File /var/log/mail.warn No mail.warn
File /var/log/mail.err Yes mail.err
File /var/log/news/news.crit Yes news.crit
File /var/log/news/news.err Yes news.err
File /var/log/news/news.notice Yes news.notice
File /var/log/debug No news.none ; mail.none
File /var/log/messages No mail,news.none
Users :omusrmsg:* Yes *.emerg
File /dev/tty8 No *.=notice ; *.=warn
Named pipe /dev/xconsole Yes *.=notice ; *.=warn
File /var/log/apache2/error.log Yes Apache error log View…
Output from dmesg Yes Kernel messages View…
File /var/usermin/miniserv.error Yes Usermin error log View…
File /var/webmin/miniserv.error Yes Webmin error log View…
Add a new system log.

If you log into your server as root over SSH, you should have a directory named “/home”.

Within that, you should see a sub-directory named after your Virtual Server owner.

Do you see that? If so, does it contain a “logs” directory?


yes i see the home directory, there is nothing in it. i wish there was, i’ll take a screenshot of all my directories if it helps. i don;t know what else to do about the log, short of asking ramnode where it is.

i started clean again, this time i only installed webmin. then through webmin i installed php5. it continued to work as normal after reboot. so it seems it has to do with virtualmin’s install process or perhaps with ramnode, my provider.
i can go with just webmin, but it’d better to have both.

i can’t believe i seem to be the only one this has happened to.
somebody has to be able to reproduce this failure.