Virtualmin GPL install fails on Centos 6.4

Install log attached - I can’t see any errors but it seems to fail after checking the PHP dependencies. The server has php 5.6 installed and I don’t really want 5.3 installed if that is the issue?

This is an install for a client. I am pretty familiar with Ubuntu but not Centos so not sure how to resolve this.

cat /etc/redhat-release CentOS release 6.4 (Final)

--> Processing Dependency: php-common(x86-64) = 5.3.3-40.el6_6 for package: php-odbc-5.3.3-40.el6_6.x86_64 ---> Package php-snmp.x86_64 0:5.3.3-40.el6_6 will be installed --> Processing Dependency: php-common(x86-64) = 5.3.3-40.el6_6 for package: php-snmp-5.3.3-40.el6_6.x86_64 ---> Package php-xmlrpc.x86_64 0:5.3.3-40.el6_6 will be installed --> Processing Dependency: php-common(x86-64) = 5.3.3-40.el6_6 for package: php-xmlrpc-5.3.3-40.el6_6.x86_64 --> Running transaction check ---> Package db4-utils.x86_64 0:4.7.25-17.el6 will be updated ---> Package db4-utils.x86_64 0:4.7.25-18.el6_4 will be an update ---> Package e2fsprogs.x86_64 0:1.41.12-14.el6 will be updated ---> Package e2fsprogs.x86_64 0:1.41.12-21.el6 will be an update ---> Package e2fsprogs-libs.x86_64 0:1.41.12-14.el6 will be updated ---> Package e2fsprogs-libs.x86_64 0:1.41.12-21.el6 will be an update ---> Package glibc-common.x86_64 0:2.12-1.107.el6 will be updated ---> Package glibc-common.x86_64 0:2.12-1.149.el6_6.5 will be an update ---> Package kernel-headers.x86_64 0:2.6.32-504.8.1.el6 will be installed ---> Package libselinux-utils.x86_64 0:2.0.94-5.3.el6 will be updated ---> Package libselinux-utils.x86_64 0:2.0.94-5.8.el6 will be an update ---> Package libss.x86_64 0:1.41.12-14.el6 will be updated ---> Package libss.x86_64 0:1.41.12-21.el6 will be an update ---> Package php-imap.x86_64 0:5.3.3-40.el6_6 will be installed --> Processing Dependency: php-common(x86-64) = 5.3.3-40.el6_6 for package: php-imap-5.3.3-40.el6_6.x86_64 ---> Package php-mysql.x86_64 0:5.3.3-40.el6_6 will be installed --> Processing Dependency: php-common(x86-64) = 5.3.3-40.el6_6 for package: php-mysql-5.3.3-40.el6_6.x86_64 ---> Package php-odbc.x86_64 0:5.3.3-40.el6_6 will be installed --> Processing Dependency: php-common(x86-64) = 5.3.3-40.el6_6 for package: php-odbc-5.3.3-40.el6_6.x86_64 ---> Package php-snmp.x86_64 0:5.3.3-40.el6_6 will be installed --> Processing Dependency: php-common(x86-64) = 5.3.3-40.el6_6 for package: php-snmp-5.3.3-40.el6_6.x86_64 ---> Package php-xmlrpc.x86_64 0:5.3.3-40.el6_6 will be installed --> Processing Dependency: php-common(x86-64) = 5.3.3-40.el6_6 for package: php-xmlrpc-5.3.3-40.el6_6.x86_64 --> Finished Dependency Resolution You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest FATAL - 2015-01-29 03:03:45 - Fatal Error Occurred: Something went wrong during installation: 0 FATAL - 2015-01-29 03:03:45 - Cannot continue installation. FATAL - 2015-01-29 03:03:45 - Attempting to remove virtualmin repository configuration, so the installation can be FATAL - 2015-01-29 03:03:45 - re-attempted after any problems have been resolved. FATAL - 2015-01-29 03:03:45 - Removing temporary directory and files. FATAL - 2015-01-29 03:03:45 - If you are unsure of what went wrong, you may wish to review the log FATAL - 2015-01-29 03:03:45 - in /root/virtualmin-install.log

Howdy – it looks like you marked this request as private, which means I’m the only person who can see it :slight_smile:

I’m happy to help, but is there any chance you could uncheck the “Private” option?

Which PHP version is it that you’re hoping for?

Also, what is the output of this command:

rpm -qa | grep php

Hi, sorry, have unchecked that option now. I need PHP 5.6.

rpm -qa | grep php php-pecl-igbinary-1.2.1-1.el6.remi.5.6.x86_64 php-pgsql-5.6.5-1.el6.remi.x86_64 php-mcrypt-5.6.5-1.el6.remi.x86_64 php-mysqlnd-5.6.5-1.el6.remi.x86_64 php-pecl-memcache-3.0.8-3.el6.remi.5.6.x86_64 php-pecl-mongo-1.5.8-1.el6.remi.5.6.x86_64 php-cli-5.6.5-1.el6.remi.x86_64 php-common-5.6.5-1.el6.remi.x86_64 php-pecl-zip-1.12.4-2.el6.remi.5.6.x86_64 php-5.6.5-1.el6.remi.x86_64 php-pdo-5.6.5-1.el6.remi.x86_64 php-pecl-msgpack-0.5.5-7.el6.remi.5.6.x86_64 php-pecl-sqlite-2.0.0-0.6.svn332053.el6.remi.5.6.x86_64 php-pecl-memcached-2.2.0-3.el6.remi.5.6.x86_64 php-gd-5.6.5-1.el6.remi.x86_64 php-pecl-apcu-4.0.7-1.el6.remi.5.6.x86_64 php-mbstring-5.6.5-1.el6.remi.x86_64 php-xml-5.6.5-1.el6.remi.x86_64 php-process-5.6.5-1.el6.remi.x86_64 php-pear-1.9.5-3.el6.remi.noarch php-pecl-jsonc-1.3.6-1.el6.remi.5.6.1.x86_64

Howdy,

Ah, that may be the source of the problem. It looks like you have a third party repository enabled there, and that may be causing a conflict that’s preventing the Virtualmin installer from running.

The installer is expecting a brand new, fresh CentOS installation, and packages coming from other repositories can cause it to fail.

Even after Virtualmin is installed, packages from third party repositories can cause various problems, so we’d advise caution using those.

A supported way of using a more recent PHP version on CentOS 6 would be to use the CentOS SCL repository. Directions for using that are available here:

https://www.virtualmin.com/documentation/web/multiplephp

Note that for it to work, you’d need to be using the 64 bit architecture.

It’s not using PHP 5.6, though it’s still much newer than the PHP 5.3.3 that comes with CentOS 6.

-Eric