Virtualmin Fresh Installation


I just installed my new SUSE 11.2 O/S. I followed the virtualmin automated installation of I was only halfway and it stopped with an error message saying that it failed to install as O/S is unsupported or unknown or unrecognized.

So I tried to download the tar.gz to my /usr/local/src and unzip the file. Now, I don’t know what to do next as I cannot do ./configure, make, and make install, neither, do a command ./ whatsoever as it is not available. I kept on searching high and low here and the internet for an answer and never found one.

I already installed webmin and usermin in the my system and the rest of the needed servers. Can someone please help me on what to do with the extracted virtualmin files.?

I would definitely appreciate any help…


Well, the problem you’re running into is that Suse 11.x isn’t supported by the Virtualmin Pro installer… and no version of Suse is supported by the Virtualmin GPL installer.

You can see the list of supported OS’s and distros here:

So, it’ll be an uphill battle to try and get things working with Suse, though it’s certainly possible :slight_smile:

You can see instructions on performing a manual installation here:

But, just remember that a lot of the packages that are made available for supported distros won’t be available.


Okay… that sounds depressing.

I will try doing the manual installation and see what happens. I hope it’s not that “uphill” as you say.

I will be back…

Okay… here am I again.

I think I read about this warning/error in one of the threads here and in fact posted a follow up question. I was able to install virtualmin module through webmin now, when I tried to do the Checking of configuration, I got this warning:

… your system is not ready for use by virtualmin.

Problem: The Suexec command on your system is configured to only run scripts under /srv/www, but the Virtualmin base directory is /home.

So now how am I going to change the system’s configuration? I hope there’s a step by step guideline for this. I don’t have any other website installed in this server yet. I just freshly installed SUSE 11.2 and the rest of the needed stuffs to make it work.

Please advice.

Thanks again.

The error you’re seeing above is because the version of suexec you’re using isn’t compiled for use with Virtualmin.

You can solve that by either:

  1. Get ahold of the Apache packages for Suse, and recompile suexec to use /home rather than it’s default of /var/www. This is the most secure way, if you’re intending on setting up a multi-user shared hosting server.

  2. You can always disable suexec, if you aren’t concerned with multiple users, or untrusted web apps. You can disable it in System Settings -> Server Templates -> Default -> Apache Website -> “Automatically add appropriate SuExec directive?”.

I think I will do the 1st option because I will use it on setting up a multip-user shared hosting server. Do you have any idea on where to obtain Apache packages for Suse, and how to recompile suexec?

Thanks again.

I have documented rebuilding Apache from an SRPM a few times here in the forums…should be findable with a bit of searching. Rebuilding SRPMs is not a big ordeal, so don’t be too intimidated by it. This is actually one of the less time-consuming and complicated aspects of setting up a Virtualmin system manually.

The really complicated parts are in the mail processing stack, though Virtualmin won’t warn as much about issues there, as it supports such a wide variety of configurations and it just kind of assumes you know what you’re doing if you’re doing it differently than we do it in the installer.

There is a Perl script in the lib directory here:

It includes all of the configuration steps that happen on all operating systems. Though older SUSE versions were supported by this script, it has been at least two years since I’ve done any work on SUSE support (the demand for SUSE was so low that it just couldn’t be justified; we literally only had one paying SUSE customer at the time I ended support for it, and the package manager on SUSE made it incredibly hard to support, and filing bugs with the SUSE folks led to repeated closures without correcting the bugs…they just sucked the will to support the platform right out of me). Anyway, because it’s been several revisions since it has been tested, I do not recommend you just run the script on your system. You should instead read is to see what it’s doing, and do those steps manually. Takes longer, but by the time you’re done, you’ll probably actually understand how Virtualmin works with your system, and you’ll be more awesome for the trouble.

If you have specific questions, we can usually help. But, you’ll need to be willing to learn a lot more than using Virtualmin on a supported OS requires.