Virtualmin fails to restore MySQL databases from backups!

I have a severe problem. My server went bust and i am restoring all the domain backups on a new machine.
However, restoration of mysql dbs fails with this message: " load failed! ERROR 1064 (42000) at line 1: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘hosts=localhost’ at line 1"
what can i do to fix this?

Are both systems identical (version etc)?

That’s weird. A dump should be compatible even if the version of the database changed (though it may only be safe to go forward, rather than back, since new stuff is introduced along the way).

What OS and MySQL version was the backup created on? And what OS and MySQL version do you have on the new system?

What does the database dump file actually look like? I don’t think “hosts=localhost” is a valid MySQL statement, so something seems to be amiss here. Are you using the Virtualmin restore feature? It ought to do the right thing, if you have backups created with the Virtualmin backup feature.

To avoid duplication of efforts – Hal9000 had also opened a bug report here, which is now listed as resolved:

Sorry for not getting back: clicking on the link in the notification emails opened the issue instead of this thread and I got confused.
This issue is not urgent for me anymore, as I got the broken server to boot again.
Nevertheless, I guess it should be solved
Both systems were identical: Debian 6.0.1 x64 with the latest Virtualmin Pro. Same versions of MySQL of course.
The backups were created by Virtualmin in bz2 format, one archive per domain, and I used the Virtualmin restore feature to restore them. Both the full and the incremental backups failed to restore the MySQL databases with the same error.
I just extracted a backup file to see how the dumps look like. Here is what I got:
the .backup/foodomain_mysql file contains:


Which is exactly what the error message is about.
The foodomain_mysql_dbname.gz files however seem to contain a normal dump.
I hope I could help you with this information. If you need me to test something let me know.