Virtualmin -- Failed to login to POP3 server : Internal error occurred.

Hi, I’m currently testing out Virtualmin GPL to see if it fits our needs, everything works great.
However after sending a test email to my newly created Usermin email, I tried logging in via: https://website.com:20000

This is the error I got:
An error occurred listing mail in this folder : Failed to login to POP3 server : Internal error occurred. Refer to server log for more information. [2009-10-07 11:38:44]

Here is the mail.err log:
Oct 6 14:26:24 sic dovecot: IMAP(dsinoc): mkdir(/var/lib/dovecot/index/dsinoc/.INBOX) failed: Permission denied
Oct 6 14:26:24 sic dovecot: IMAP(dsinoc): mkdir(/var/lib/dovecot/control/dsinoc/.INBOX) failed: Permission denied
Oct 6 14:26:24 sic dovecot: IMAP(dsinoc): mkdir(/var/lib/dovecot/index/dsinoc/.INBOX) failed: Permission denied
Oct 6 14:26:24 sic dovecot: IMAP(dsinoc): mkdir(/var/lib/dovecot/control/dsinoc/.INBOX) failed: Permission denied
Oct 6 14:26:24 sic dovecot: IMAP(dsinoc): mkdir(/var/lib/dovecot/index/dsinoc/.INBOX) failed: Permission denied

However, if I log in via root to the virtualmin (website.com:10000) and choose “read user mail” I can read all mail without error.

Any help/advice?
Thank you

Howdy,

If you type:

grep mail_location /etc/dovecot/dovecot.conf

on the command line, what do you see?

You might try setting that to:

mail_location = maildir:~/Maildir

Hi andreychek,
Thank you for such a fast reply!

Here is what I get:

sic:~# grep mail_location /etc/dovecot/dovecot.conf

path given in the mail_location setting.

mail_location = maildir:~/Maildir

mail_location = mbox:~/mail:INBOX=/var/mail/%u

mail_location = mbox:/var/mail/%d/%1n/%n:INDEX=/var/indexes/%d/%1n/%n

#mail_location =
mail_location = maildir:~/Maildir:INDEX=/var/lib/dovecot/index/%u:CONTROL=/var/lib/dovecot/control/%u

namespaces completely, they use only the mail_location setting.

explicitly, ie. mail_location does nothing unless you have a namespace

mail_location, which is also the default for it.

dovecot’s mail_location setting used by the mail protocol daemons.

managesieve daemon uses the specification of the mail_location to find out

The example below, when uncommented, overrides any global mail_location

mail_location = mbox:~/mail

converted to destination storage (mail_location) when the user logs in.

So I should change “mail_location = maildir:~/Maildir:INDEX=/var/lib/…” into just “mail_location = maildir:~/Maildir” ?

Once again, Thank you

Yeah, change that to the value what I mentioned above – and then restart Dovecot. I think that’ll take care of the issue for you… let us know if not :slight_smile:

-Eric

Yes, that fixed it! Thank you soo much, I will definitively begin saving money for the professional version.

Once again, Thank you!

Thanks guys this helped me even.

Is this done by an update of dovecot?

Fix it also for me !
Tks :slight_smile:


Ced
www.lineaire.net

This does work. Thank God. I just nearly had a heart attack.

I updated Dovecot and immediately got error messages similar to those in the first post.

The above fix works, although my dovecot.conf is at

/etc/dovecot.conf

Set mail_location as follows :

mail_location = maildir:~/Maildir

and restart Dovecot.

I’m always scared of updating software on live production servers because of unexpected errors such as these.

Christmas Eve is not a good time to be messing about with a live server. I’m still trembling a little, but at least the colour has come back to my face and I’ve stopped sweating. God, that was a scary moment.

Thanks for providing the answer!