Virtualmin error: No Ethernet interface

Hi, I am really new to linux and virtualmin. I just paid for a virtual dedicated/private server having CentOS 5.0 I wanted to try the free virtualmin before i upgrade to the paid licenced version.

Before installing Virtualmin GPL. I was able to upgrade CentOS to the latest CentOS 5.2 and other requirements before installing. But now i am having the following error on Virtualmin when i do thr Re-check and Refresh configuration: No Ethernet interface could be automatically found on your system. Use the module configuration page to set the interface manually.

[color=#FF0000]… your system is not ready for use by Virtualmin.[/color]

HERE IS MY SERVER DETAIL:

Operating system: CentOS Linux 5.2
Webmin version : 1.420
Virtualmin version: 3.59.gpl (GPL)
Kernel and CPU Linux: 2.6.9-023stab044.4-smp on i686

I REALLY NEED AN URGENT HELP TO RESOLVE THIS PROBLEM AND MAKE VIRTUALMIN WORK. I SHOULD ALSO POINT OUT AGAIN THAT I INSTALLED ON A VIRTUAL DEDICATED SERVER. PLEASE HELP.

Here is the complete report when i did Re-check and Refresh:

The status of your system is being checked to ensure that all enabled features are available, that the mail server is properly configured, and that quotas are active …

BIND DNS server is installed, and the system is configured to use it.
Mail server Postfix is installed and configured.
Apache is installed.
Webalizer is installed.
Apache is configured to host SSL websites.
MySQL is installed and running.
ProFTPd is installed.
Logrotate is installed.
SpamAssassin and Procmail are installed and configured for use.
ClamAV is installed and running.
Plugin DAV Login is installed OK.
Plugin AWstats reporting is installed OK.
Plugin Mailman is installed OK.
Plugin Protected web directories is installed OK.
No Ethernet interface could be automatically found on your system. Use the module configuration page to set the interface manually.

[color=#FF0000]… your system is not ready for use by Virtualmin.[/color]

Please help needed.<br><br>Post edited by: chrisazuka, at: 2008/08/06 10:44

It looks like it doesn’t know which ethernet device to use. If you run an “/sbin/ifconfig” from the command line, what interfaces show up besides lo?

What you’d then need to do is go into System Settings -> Module Config, and set “Network interface for virtual addresses” to your network interface.

Normally, this is “eth0”, but some VPS’s have unusually named network interfaces.
-Eric

all the VPS’s I know have venet0, you can check that in webmin-networking module.

and caps is crap to read too

Hi Andrey and Ronald, Thanks for your reply. i appreciate this.

I checked through the webmin-networking module as directed by Ronald and apart from lo, i can see three other interfaces namely: venet0 having 127.0.0.1 as IP, venet0:0 and venet0:1 having two different public accessable ip and they are all showing status as: Up

what should i do now, which of the interfaces should i use?
am i to use the name of the interfaces or their ip coresponding with the name? and where in the System Settings -> Module Config should i place them?

It sounds like your provider simply gave you two IP’s, so one isn’t necessarily better than the other.

If it were up to me, I’d probably use the first, venet0:0, but it’s ultimately your call :slight_smile:

You can tell Virtualmin about it by going into System Settings -> Module Config, then add it into the "Network interface for virtual addresses" field.

Save that, then go into System Settings and choose "Re-Check Config".
-Eric

This is actually a little trickier than usual, since the primary “interface” is a loopback IP. So, the “Interface for virtual addresses” should actually be venet0, since virtual interfaces (venet0:0) can’t have their own virtual interfaces (like venet0:0:0, I don’t think…). But you’ll also need to fill in the “Default virtual server IP address” and set it to the IP of venet0:0.

This will only come into play if you are using multiple IP addresses for Virtualmin hosts, of course.

Thanks, for clarification i should use the name "venet0:0" not the IP linkd to venet0:0 ?

hi Joe, My host actually gave me 3 IPs but i have only requested for 2 to use 1 later.
are you saying if i’m to use venet0:0, i should also specify the IP address manually in the Default virtual server IP address field. Or are you advicing i use venet0?

"Interface" should be venet0, because it needs to be the actual interface, rather than one of its virtual interfaces (or "alias" interfaces).

The address in the next field should be the first IP–the one assigned to venet0:0.

Hi Joe, Andrey and Ronald, Thanks for your help. Finally i saw the message: … your system is ready for use by Virtualmin.

You have been very helpful, thank you. this has also busted my confidence in using linux OS and of course not without the helper (Webmin+Virtualmin).

thank you.

Here is another problem i’m xperiencing; i see that a New version 2.2.3-7el5.2vm of Apache HTTP Server is avilable.

When i tried updating, i got this error message:
ERROR with rpm_check_debug vs depsolve:
Package turbopanel-tomcat needs mod_jk >= 1.2.0, this is not available.

But on checking Software Packages through Webmin, i can see that mod_jk Version 1.2.26-1.el5.gdg is already installed on my server but virtualmin is somehow not seeing it.

though mod_jk is showing some few error as below:

/etc/httpd/conf.d/jk.conf (View) root root Editable File OK
/etc/httpd/conf/workers.properties (View) root root Editable File OK
/usr/lib/httpd/modules/mod_jk.so (View) root root Regular File 682.68 kB Failed modification time check
/usr/share/doc/mod_jk-1.2.26 root root Directory OK
/usr/share/doc/mod_jk-1.2.26/CHANGES (View) root root Regular File 60.10 kB Failed modification time check
/usr/share/doc/mod_jk-1.2.26/NEWS (View) root root Regular File 29.10 kB Failed modification time check
/usr/share/doc/mod_jk-1.2.26/README.txt (View) root root Regular File 1.76 kB Failed modification time check
/usr/share/doc/mod_jk-1.2.26/STATUS.txt (View) root root Regular File 1.97 kB Failed modification time check
/usr/share/doc/mod_jk-1.2.26/conf root root Directory OK
/usr/share/doc/mod_jk-1.2.26/conf/workers.properties (View)
root root Regular File 6.30 kB Failed modification time check
/usr/share/doc/mod_jk-1.2.26/conf/workers.properties.minimal (View)
root root Regular File 1.29 kB Failed modification time check

I tried to uninstall mod_jk so that i can re-install but that didn’t work either. webmin refuse to uninstall it.

i tried to install without uninstall since webmin refuse to install the one there already but webmin could not install the .so file.

What should i do in order to upgrade?

what should i do

i suspect you need to set the clock, this happens with different timezones on the vps’s.
You can’t set the hardware clock.

in the webmins-hardware-system time - module config - change the "Acceptable number seconds of delay between system time and hardware time" to 10000000000000000

It cant change if the time is set to 5 for instance and you’re in a different timezone. and set the “System supports hardware time” to no.

Then you can set it to your timezone and have ntp sync it (install ntp if its not there)

I had such a problem on a server out of my timezone once and this helped me.

Hi ronald, thanks for your tips. I tried following ur instruction but i still couldn’t have it work. I also noticed seeing this error below at the System Time page: hwclock failed