Virtualmin error: io-error. Can't ping or access Virtualmin for configuration.

Hi,
Virtualmin was running slowly, so I set my servers to reboot everyday at 03:00, rather than leaving Virtualmin on all the time.

Worked for a week or so, but today I noticed Virtualmin is locked up.
I can’t ping (Destination Host Unreachable).
Proxmox shows Virtualmin server status error: io-error.

I can’t shutdown Virtualmin.
I reboot Proxmox and Virtualmin works and websites are up.
However one website’s forum gives error:
The requested resource could not be loaded because the server returned an error:
  404 Not Found (?). Return to index.

Then after 10 minutes Virtualmin is locked up and Proxmox running Virtualmin gives error status: io-error.

Any suggestions how to make Virtualmin work?

So, rebooted Proxmox and Virtualmin runs.
Selected Proxmox’s Webserver (Virtualmin) and accessed Console.
CentOS opens and I go to CentOS > System > Preferences > Network Connections > error:
An internal system error has occurred.

Howdy,

The 404 error you’re receiving may just be a configuration error for the website of that particular domain.

The other errors you’re seeing are unusual though, and may indicate a deeper problem with your VPS, hardware, and/or resources.

Is this VPS from a provider?

Or did you set it up on your own?

If it’s from a provider, you may want to talk to that provider about the io-errors and “internal system” errors that you’re seeing, and see if they have any info about them.

-Eric

I have deleted the entire Proxmox VM Virtualmin Server.
I created a new Proxmox VM.
Installed CentOS.
In CentOS > Applications > Internet > Firefox Web Browser > http://www.virtualmin.com/download.html > Virtualmn GPL Downloads > Linux and FreeBSD > Save File > OK > Applications > System Tools > Terminal > cd / > cd root/Downloads > /bin/sh install.sh > y > Enter > Please enter a fully qualified hostname: centos.com > Enter (allow about 10 minutes for install) > Error:
Failed to initialize. Failed to initialize packaging backend. This may occur if other packaging tools are being used simultaneously. There are unfinished transactions remaining. Plesae run yum-complete-transaction as root.

I then run Terminal > sudo yum-complete-transaction.
The following error repeats over and over: error: rpmdb: damaged header #1203 retrieved – skipping.

How to fix Virtualmin?

I haven’t run into that particular error before, though it suggests that the RPM database is corrupt for some reason.

Googling that error, I found this particular mailing list thread, which may help in resolving it:

http://lists.centos.org/pipermail/centos/2007-October/045183.html

That may suggest that there’s another problem going on with your server though…

-Eric

Thank you for the replies.
I have deleted the Virtualmin VM server.
I then reinstalled CentOS and same error.
I then downloaded and installed CentOS6.5 and same error.
I then downloaded and installed CentOS6.5 from a different mirror and error not occurring.

See how it goes for a few weeks.
Now my Virtualmin setup of the website gives the error:
General Error: SQL ERROR [mysql4]. Access denied for user ‘root’@‘localhost’ (using password: NO) [1045]. An sql error occurred while fetching this page. Please contact an administrator if this problem persists.

I need to fix this, as I haven’t worked out backups and restores yet.