VirtualMin Disappeared

I’ve been running virtualmin for some time, but is has disappeared. I rebooted server the other day, and after reboot, I can find no traces of virtualmin.

I’m not a Linux Guru by any means, but I can usually find my way around.

Does anyone know where I can begin to try to figure out what happened?


Hey Richard,

What am I doing wrong. Do I need to buy the professional version?

Yes! Everyone needs to buy the Professional version right away, my car payment is due…You’re getting very sleepy…you must buy the Professional version. You must buy three…no, wait…a dozen of the Professional version!

Just kidding, of course. There’s no need to buy the Professional version–we’re happy to have you as a GPL user, too, and it never times out or anything like that.

I’m sure your trouble is something simple.

Some things to check:

Browse to Webmin:Webmin Users

Click on the root user (or whoever you login as to administer Virtualmin).

In the list of "Modules" at the bottom of the page, make sure Virtualmin is selected.

It might have moved to another category (not on its own, but you or another admin might have accidentally moved it), browse to Webmin:Webmin Configuration and click on "Reassign Modules". Find Virtualmin Virtual Servers and make sure it lives in Servers (or make a note of what category is now has, if you like it better there).

Hope this helps. Holler if it doesn’t and I’ll see if I can figure out some other reason for it to have disappeared. But I’m pretty sure it’s one of these.


Thank you so much for your speedy reply. You were right on. It had been moved from my user. No one has fested up to it yet.

Your speedy reply and hypnosis worked. I will be contributing to your car payment soon.

Thanks again.


Hey Aaron,

You’re going to have to be more specific than “I can find no trace of virtualmin”. Where did you look? Did you just try to login, or did you actually check running processes, the directory where Webmin (and thus Virtualmin) is installed, etc.?

First guess would that for some reason Webmin isn’t set to run on boot. Start it with:

/etc/init.d/webmin start



Sorry for being vague… It’s not intentional, it’s more lack of knowledge.

Webmin is running, but I have no virtualmin.

In /etc/webmin I have the following - virtualmin-dav, virtualmin-htpasswd, virtualmin-mailman, virtualmin-svn, virtual-server

If that helps any…


Hey Aaron,

Ah. Ok, "virtual-server" is Virtualmin.

It could be that the theme has been changed from a Virtualmin focused theme, to a regular Webmin theme that does not offer the Virtualmin menu. “Virtualmin Framed Theme” is the only one that has the left-hand menu (at this time, though we have another one in development). If using a different theme, it could look like Virtualmin is gone, when really it’s hiding under the Servers menu in Webmin. Switching back to the Virtualmin Framed Theme.

If that’s not the case, it could be disabled for your user. Browse to Webmin:Webmin Users, and click on the user you use to login for administrative tasks (usually root). Scroll to the Servers section and then make sure Virtualmin Virtual Servers is checked.

VirtualMin is no longer in the Servers tab… Nor does it show as an option for any user in Webmin Users. I am logging in to WebMin as root.

I checked there to see if it was just unchecked for some reason, but it’s not there.

I’m the only one with access to this box, so unless someone has broken in, I don’t think anyone is messing with me.

Anything I can check in /virtual-server?


Would a re-install of Virtualmin hurt? Will it maintain the domains that are already there from Virtualmin before it disappeared?


Hey Aaron,

If by “re-install” you mean run again, don’t do it! is for installing Virtualmin, and once installed should never, EVER, be run again. It does dramatic things to a system, and this is not a problem in need of dramatic actions.

If by re-install you mean “yum install wbm-virtual-server” (replacing “yum” with whatever your operating system’s package manager is), then sure, you could try it. That’ll never hurt anything, but it probably won’t fix it either.

But, I believe we’d rather figure out what’s wrong.

First up, find out if the package is installed.

rpm -q wbm-virtual-server

Or, on Debian/Ubuntu:

dpkg -s webmin-virtual-server

If yes, proceed to:

ls /usr/libexec/webmin/virtual-server # If installed from RPM


ls /usr/share/webmin/virtual-server # If from a .deb

If this directory exists, and contains a bunch of files…then we check /etc/webmin/virtual-server (I believe you’ve already said this exists, so it’s probably not an issue).

Finally, worst case, send me the login details and address via email at and I’ll spot the problem and fix it.

…and this post’s suggestion fixed it for me.