Virtualmin - Disable/Enable Virtual Server

I was troubleshooting some performance issues on my server and in the process disabled two Virtual Servers in Virtualmin under the “Disable & Delete” menu. When my troubleshooting was complete, I tried to enable the two Virtual Servers and am now seeing the following message when I go to the Virtual Server’s associated web page:

"Internal Server Error

The server encountered an internal error and was unable to complete your request.
Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.
More details can be found in the server log."

I tested this procedure on a third server, disable and then enable, and ended up with the exact same results. Is there an additional step that I am missing to get these Virtual Servers re-enables?


Okay, I seem to have solved my own problem and either uncovered a bug or missed some key documented information.

Upons performing some additional troubleshooting, I found that the error I was seeing was related to the website not being able to connect to its associated database. I tested on the command line with the DB username and password, and was unable to connect. The simple fix was to change the password to something like “test” then change it back to the original password. Once I did that, everything worked.

I was able to reproduce this issue on all of my domains in Virtualmin. Disable and then re-enable will cause the DB user credentials to no longer work, rendering any website that is DB driven to no longer operate. Hopefully this helps someone in the future.