Virtualmin "Default IP address for DNS records" IPv6 issue.

Hi!

I’m running my web server with dual stack IPv6/IPv4, the IPv4 address is behind a NAT, and the IPv6 address is public. My problem is that if i set the option in “Networking Settings” under Virtualmin Configuration to “Automatically detect external address” the virtual servers do not get the IPv6 records in BIND that they do if i choose the option “Same as virtual server IP”.

This is no issue when running this as a Web server. But i want to use this server to host my domain names too, as it’s simpler to have the domain names DNS records handled by Virtualmin.

Is there any solution to my problem? I’ve tryed to force it to my public address using the option “Other address” followed by the public IPv4 address.

Thanks.

Howdy,

Hmm, I’ll talk to Jamie about that. Virtualmin is prepared for a server to be behind NAT, or on a public network – but I’m not sure it understands how to handle the case where different interfaces are on one of each :slight_smile:

-Eric

This kind of setup where the IPv4 address is behind NAT but the IPv6 address is “real” should work fine.

Make you sure that on the domain creation form in the “IP address and forwarding” section, the “IPv6 network interface” field is set to either “Create now with allocated IP” or “Add with address”.

I’ve checked the “Create now with allocated IP” (May there be a option for automaticly doing that on server creating?) but it still don’t work. Only if i use the same ip as virtual server for DNS, which is “192.168.20.32”. But i won’t since i need my DNS records to point to my public ip.

Are you also using a public IPv6 address but a private IPv4 address?

Yes, correctly :slight_smile: But it is the DNS IPv6 address that does not work when DNS IPv4 address is set to other also specified in the VirtualMin Configuration.

So what is the IPv6 address being set to in your DNS configuration? It is an internal IP when you’d actually like it to be a separate external IPv6 address?

No, there are just no IPv6 address set in the DNS zone for created virtual servers :frowning:

On the domain creation form, do you have “IPv6 network interface” set to “Create now with allocated IP” or “Add with address” ? Without selecting one of those, no IPv6 address or DNS records will be added.