Virtualmin Creating New IP Address Did Not Work

Operating system: Centos
**OS version:**8.3.2011

I am running Centos 8 on a new Virtual Private Server. I purchased a new IP address from my provider, and I wanted to add it to my server. I followed several step by step guides to do this, by going into Webmin and adding a new network interface, then adding the gateway for the IP. Finally, I went into Virtualmin and clicked on Change IP address for each of the two virtual servers I had created.

Prior to attempting to change the IP address, the server was correctly setup, with each of the virtual servers I had created resolving properly, and with the email addresses I also created routing mail properly. I had also installed an SSL certificate, which was also functioning correctly.

However, upon changing the IP address in Virtualmin and Webmin, the virtual servers will not resolve at all (timing out instead) every time I try to load them. The virtual servers no longer work at all, and are presently down and not functioning. As I had mentioned, they were working correctly prior to this change, and I have changed nothing else.

In order to change the IP address, I changed the Network Configuration in Webmin, adding the new network interface as a sub-interface of the main interface that was in use, so eth0:0 is the new interface. I also added the gateway in the main Network Configuration menu. Then I switched to Virtualmin, clicked Server Configuration, and clicked on Change IP Address.

After doing this, the virtual servers will no longer resolve.

When I checked in the DNS records for Webmin, for the Master Server that was auto-created by Virtualmin, the listed IP addresses in the Master Server were the old IP addresses. I thought that perhaps this was what was causing the issue, so I changed them manually to the new IP address.
However, now when I open Virtualmin and click on Server Configuration, DNS Records, I get the following error: Warning! Warning - errors were found in this domain’s DNS records : The DNS record resolves to the IP address (new IP address) instead of the virtual server’s IP (old IP address).

So, clearly this was not the correct way to solve this issue.

I have changed the DNS records back to the old IP address, as they were before, in the master server area, but I am still stuck as to how to proceed and make the server recognize and resolve to the new IP address. I have also flushed my DNS resolver cache on my computer, to no avail. No matter what I do, it still times out. Everything was working perfectly until I changed the IP address (which I incorrectly thought would be very simple to do).

In addition, I tried checking the configuration in Virtualmin for the virtual server using System Settings: Re-check Configuration, and everything comes up as working properly, with the new IP address listed as the IP for the server.

I entered the correct gateway, broadcast address, and IP address, so there were no errors in that regard. As I had it set up before, changing the IP address in Virtualmin should have worked, and the site should have resolved properly. However, it is not.

I have also checked it from my phone, which I had not used previously to visit the site, and it still does not work. Can you please help me to know what I did incorrectly? Perhaps there is a step by step guide that would show me how to fix this, that I was unable to find. Your help is greatly appreciated. Thank you.

Hello @anne282 and welcome to the community.

Yes, you should not have used Webmin to add the IP address. Doing it via Virtualmin is the recommended way to accomplish this. See:

Thank you for your help. I had actually started out using just Webmin, then recently switched over to Virtualmin, so I know how to do a few things in Webmin directly, that are now completely different using Virtualmin.

When you said poke around in Server templates, I don’t exactly know what I am looking at there. When I look in Virtual IP Address, I see that there are default settings (which is what are currently being used) and then I can specify a range. If I have an IP address, what would be an appropriate IP address range? From 0 to 255 in the last field of the IP?

I also want to ask two other questions.
1- Since I did it wrong, and started in Webmin, should I delete the entries in Webmin and just use the Change IP address command in Virtualmin? Or is there somewhere that I need to set the new IP in Virtualmin so that the Change IP command knows where to find the IP to use?

2- Do you have a step-by-step guide to changing the IP address that you have the link to? I could not find directions in the tutorials on the Virtualmin page, and am having difficulty figuring out where I should start.

3- Is there a complete Virtualmin guide that can be downloaded as a PDF that might have solutions to this and other issues that one might run into on a server using VM as the GUI? I wanted to put it in my Kindle so that I can learn how to fully use this interface, but have been unsuccessful in finding it.

Your help is greatly appreciated. I find VM to be a very useful interface, and once I am successful in getting the IP to work, I can move on to setting up several other servers using VM as the GUI. I have several other websites that I want to host on the VPS, but have to get this issue solved first. Thank you in advance.

May I request you to create a new topic for each of the things that you wish to discuss? This present topic, captioned “Virtualmin Creating New IP Address Did Not Work” should pertain to our discussing just that please.

I imagine if you have a single IP address (say then the range would be - but if you had two IP addresses then the range would be - and so on…

So, the question that I have regarding the IP addresses not working is: should I delete the entries that I made in Webmin?

If I do delete them, where are the equivalent values entered in Virtualmin (such as for gateway and netmask)?

The area you pointed me to only has the IP address range, so these other values are not defined there, and from my understanding they must be defined in order for the server to use them.

Please let me know how I should proceed in this instance. Thank you very much for your help,

Just to update you, I just entered the IP address range, with the Netmask, in the Server Templates area, without deleting the Webmin entries, and it still times out. Thanks again for your help!

Hi, I am still having problems with changing the IP address for the virtual server. When I point the DNS record to the original IP address, I get a Virtualmin “under construction” page for the main domain on the server.

However, when I point the DNS record to the new IP address, it times out while trying to connect, or gives an unknown error. I am still unable to understand why this is happening, and I would appreciate assistance in troubleshooting this problem. Thank you.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.