Virtualmin Creating 3 Name Server Entries In Bind - One Wrong

Hi All,

Seem to get one thing fixed and then something else goes wrong at the moment.

Basically when I create a new virtual server, and the BIND zone’s get created, it seems to add an extra name server entry, which is wrong. In the zone file it will look like the following

@     IN     NS

Notice the one with the double dots? This causes BIND to fail. And i cannot for the life of me find out where it is pulling this extra name server from?

I have tried going into the Virtualmin Server template and removing my secondary name server there, it removes one of them, but keeps the double dot one there.

I have looked all over the place and cannot find any other templates which will create this additional secondary name server anywhere?


So just to verify – in System Settings -> Server Templates -> Default -> BIND DNS Domain, what are the following fields set to:

Additional manually configured nameservers Master DNS server hostname

That is where I have already checked over.

Additional name server is and master is

I tried taking out ns2 from the additional, and that faulty ns2 still appeared looking like

@    IN  NS
@     IN     NS

It doesn’t pull any details from the slave DNS server does it?

Just tried the following again

Virtialmin > System Settings > Server Templates > Default > BIND

Removed additional name server, saved and tried creating new server - extra NS still exists
Unchecked “Add Nameserver record for the system” - again still exists

I’m stumped, where else would it pull the from? I’ve checked all the BIND settings, nothing in there for NS2 (only NS1).

Sussed it out! Think i found a bug in Virtualmin.

Basically when I did the cluster Webmin servers, i added the IP address of the slave server, and then gave it the hostname manually. Then when you cluster in BIND Virtualmin automatically adds two dots on the end.

I went back in and removed the webmin server index, and removed the link in BIND. Re-setup the server using the (instead of the ip address) added the server back into BIND, and now it sets everything up correctly.