# Virtualmin bleeding edge packages for PHP

**URL:** <https://forum.virtualmin.com/t/virtualmin-bleeding-edge-packages-for-php/47768>\
**Category:** Virtualmin\
**Created:** [February 7, 2014, 9:54am UTC](https://forum.virtualmin.com/t/virtualmin-bleeding-edge-packages-for-php/47768 "2014-02-07T09:54:50Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![fakemoth](https://cdn.forum.virtualmin.com/user_avatar/forum.virtualmin.com/fakemoth/32/244_2.png) [@fakemoth](https://forum.virtualmin.com/u/fakemoth)\
**Post date:** [February 7, 2014, 9:54am UTC](https://forum.virtualmin.com/t/virtualmin-bleeding-edge-packages-for-php/47768/1 "2014-02-07T09:54:50Z")

</div>

Hello, big problem for me and maybe a lot of you people: the Joomla! CMS (99% of my websites) will require php 5.3.10 or higher see here [http://community.joomla.org/blogs/leadership/1798-raising-the-bar-on-security.html](http://community.joomla.org/blogs/leadership/1798-raising-the-bar-on-security.html) and other web stuff require or at least recommend \> 5.4. The problem is always the same if we use CentOS, Scientific or Red Hat: the php versions are ancient. And I don’t think that we will get newer versions: CenTOS 6.5 fully updated uses 5.3.3 and we sure don’t have the time to wait for 6.9, just to get like 5.3.5 🙂

The “why” doesn’t matter here and we all know the answers.

Does the Virtualmin bleeding edge repo still exists (that was so cool of you) and is actively mantained? I guess not 'cause I can’t find anything about it…

If not, will you consider start it again and mantaining some decent php version? This and maybe mySQL being the most common problems for the RHEL-like servers out there. And I preffer sticking with you and not other repos, and having the two php versions side-by-side; that went oh so well 🙂

Thank you!

---

<div class="post-metadata">

**Author:** ![yngens](https://cdn.forum.virtualmin.com/letter_avatar_proxy/v4/letter/y/9de053/32.png) [@yngens](https://forum.virtualmin.com/u/yngens)\
**Post date:** [February 7, 2014, 11:33am UTC](https://forum.virtualmin.com/t/virtualmin-bleeding-edge-packages-for-php/47768/2 "2014-02-07T11:33:33Z")

</div>

The same problem exists for upcoming Drupal 8, which requires PHP 5.3.5: [https://drupal.org/node/1751100](https://drupal.org/node/1751100)

---

<div class="post-metadata">

**Author:** ![fakemoth](https://cdn.forum.virtualmin.com/user_avatar/forum.virtualmin.com/fakemoth/32/244_2.png) [@fakemoth](https://forum.virtualmin.com/u/fakemoth)\
**Post date:** [February 7, 2014, 11:48am UTC](https://forum.virtualmin.com/t/virtualmin-bleeding-edge-packages-for-php/47768/3 "2014-02-07T11:48:14Z")

</div>

Tiki requires 5.5. Moodle also already requires 5.3.3 - this will be increased in the future. Others will follow…

---

<div class="post-metadata">

**Author:** ![Eric](https://cdn.forum.virtualmin.com/letter_avatar_proxy/v4/letter/e/898d66/32.png) [@Eric](https://forum.virtualmin.com/u/Eric)\
**Post date:** [February 7, 2014, 1:40pm UTC](https://forum.virtualmin.com/t/virtualmin-bleeding-edge-packages-for-php/47768/4 "2014-02-07T13:40:52Z")

</div>

Howdy,

Are you using 64 bit CentOS?

If so, you can actually run two PHP versions side by side now. Take a peek at the documentation here, and let us know if this will help:

[https://www.virtualmin.com/documentation/web/multiplephp](https://www.virtualmin.com/documentation/web/multiplephp)

---

<div class="post-metadata">

**Author:** ![system](https://cdn.forum.virtualmin.com/uploads/default/original/2X/c/cd96d761e326db4b2bef94886a639109bd7a8e76.svg) [@system](https://forum.virtualmin.com/u/system)\
**Post date:** [April 30, 2020, 5:59am UTC](https://forum.virtualmin.com/t/virtualmin-bleeding-edge-packages-for-php/47768/5 "2020-04-30T05:59:57Z")

</div>

Closed on April 30, 2020, 5:59am UTC


