Virtualmin auto Mail client configuration


L’auto mail client configuration doesn’t work for me !
I have activated it in EMAIL SETTINGS in System settings
I want the imap and smtp server to be the name of my server (FQDN) in my client’s outlook:
–> so I edit the autoconfig.cgi file of my Vhosts to replace the variables as follows:
# These variables get replaced when the script is copied
OWNER ="";
US$ER =‘customer_domain’;
$SMTP_HOST =‘server_name_FQDN’;
$SMTP_PORT =‘465’;
$SMTP_SSL =‘yes’;
$SMTP_ENC =‘password-cleartext’;
$IMAP_HOST =‘server_name_FQDN’;
$IMAP_PORT =‘993’;
$IMAP_SSL =‘yes’;
$IMAP_ENC =‘password-cleartext’;
PREFIX = “customer_domain”;
$STYLE =‘6’;

and this part I didn’t edit:

# Outlook
print <<<EOF;

<?xml version="1.0" encoding="utf-8" ?> email settings IMAP 24 $IMAP_HOST $IMAP_PORT $SMTP_LOGIN off $IMAP_SSL on SMTP 24 $SMTP_HOST $SMTP_PORT $SMTP_LOGIN off $SMTP_SSL on EOF and despite that the names of the imap and smtp servers remain mail.customer_domain. and SSL is not even activated! What could be the problem?

In firefox https://customer_domain/cgi-bin/autoconfig.cgi?emailaddress=name@customer_domain
the information is correct, however

Thanks for help !