virtualmin, apache and php issue

Hi all
it’s 3 days that i try i can’t find a solution

I’ve installed virtualmin on a fresh installation of ubuntu
everything goes fine but one problem arise
when i try to put a php file in the directory of my (one and only) virtual server, seem that apache don’t execute it. It show a blank page
i’ve tried with the classic <?php phpinfo(); ?> but nothing
if i try with an image or a htm file everything goes right, but not withh php file. itried also to mae a php with some html tags; the html content showup but the php portion don’t.

iI’ve searched through the other forum posts to see if someone have the same issue, but the proposed solutions don’t work for me

in this three day i’ve tried on a local ubuntu 12.04 installation, and on a cloud server two times (first with ubuntu and then with debian) but the result it’s always the same

someone can help me? i don’t know where to look to resolve m issue
Thank You
Francesco

Howdy,

Ubuntu 12.04 and Debian 7 do normally work out of the box.

One thing you may want to check is to review the Apache logs for that domain to see if any errors show up.

You can find the Apache error logs in $HOME/logs/error_log.

Also, what output do you see if you run the command “php -v”?

-Eric