Virtualmin and Server confusion

am running virtualmin 3.99 and i have also some joomla installations. What happens now and then is, that if i am editing the coomla config, it will delete the content of the configuration file and show an error message: installation/index.php not found. If i copy back a backup of that file, the admin area appears and shows the message: Could not save changes.

Also, i cannot upload anything like extensions, plugins or templates, it always says, that it couldn’t create the directoriy(ies)

I have set every file and directory to the the according website user and given them 775. (if my domain would be, the user and group for apache would be example.

But the empty configuration file is owned by owner www-data and group www-data.

Joomla says, that every directory it needs is write-enabled, but isn’t able to write or create files/directories.

So why does Joomla try to write files as www-data? And how can i get it to work again?
Also, i cannot upload any file with winscp anymore. It throws an error 4; which is probably a timeout.

Any help truly appreciated.

Thanks and best


What PHP Execution Mode are you using? You can see that in Server Configuration -> Website Options.

It should only be running as www-data if your PHP Execution Mode is set to mod_php, though that mode isn’t the default.

Also, if you go into System Settings -> Re-Check Config, does that detect any problems?



mod_php, all files are assigned to user/group virtualserver owner. But this hasn’t been a problem before. I think i got this problem after upgrading to 3.99.

Re-Check Config says:

The status of your system is being checked to ensure that all enabled features are available, that the mail server is properly configured, and that quotas are active …

Your system has 15.62 GB of memory, which is at or above the Virtualmin recommended minimum of 256 MB.

BIND DNS server is installed, and the system is configured to use it.

Mail server Postfix is installed and configured.

Postfix can support per-domain outgoing IP addresses, but is not currently configured to do so. This can be setup in the Postfix Mailserver module.

Apache is installed.

The following PHP versions are available : 5.3.2 (/usr/bin/php5)

Webalizer is installed.

Apache is configured to host SSL websites.

MySQL is installed and running.

PostgreSQL is installed and running.

ProFTPd is installed.

Logrotate is installed.

SpamAssassin and Procmail are installed and configured for use.

SpamAssassin is configured to be run from the global Procmail configuration /etc/procmailrc, which is not needed as Virtualmin will set it up on a per-domain basis.

… your system is not ready for use by Virtualmin.

But it makes me wonder, that it says “your system is not ready for use by…”

Also, in php_ini there is a memory limit of 1024M, but phpinfo.php claims for a subserver just 32M. Where can i change this? locate php.ini only showed me this:

locate php.ini


Wanted to change that setting, since piwik will run, but does not save any information in its database, it claims, that 32M is not enough memory.

EDIT: I found the setting in /etc/apache2/sites-available/[domain.conf]; in case somebody else needs to change that :slight_smile:

Still wondering, and thanks for help.


What are the contents of your /etc/procmailrc file? That may be the cause of the Re-Check Config failure you’re seeing…


LOGFILE=/var/log/procmail.log TRAP=/etc/webmin/virtual-server/ :0wi VIRTUALMIN=|/etc/webmin/virtual-server/ $LOGNAME EXITCODE=$? :0 * ?/usr/bin/test "$EXITCODE" = "73" /dev/null EXITCODE=0 :0 * ?/usr/bin/test "$VIRTUALMIN" != "" { INCLUDERC=/etc/webmin/virtual-server/procmail/$VIRTUALMIN } ORGMAIL=$HOME/Maildir/ DEFAULT=$HOME/Maildir/ :0wf | /usr/bin/spamassassin :0 * X-Spam-Status: Yes $HOME/spam DROPPRIVS=yes

You don’t actually need these lines at the end of the procmailrc, you can comment these 5 lines out:

:0wf | /usr/bin/spamassassin :0 * X-Spam-Status: Yes $HOME/spam

i’ve got spamassassin running, so is it correct, if i remove this five lines?
Best and Thanks.

Yeah, those 5 lines shouldn’t be there, SpamAssassin is called by Virtualmin from another location, and are why Virtualmin is throwing that error when you run the Re-Check Config.


will remove them and try again :slight_smile: