virtualmin and php4 and 5

can virtualmin pro or gpl have php 4 and 5 on the server at the same time and make it a toggleable option?

Yup!

How to get both versions of PHP differs depending on what distro you’re using; but for something like CentOS, PHP5 comes with CentOS5, and PHP4 is in the Virtualmin repo (of course, remember that the PHP folks have stopped providing security updates for PHP4).

In Virtualmin Pro, you can set which PHP version is the default for new Virtual Servers.

You can also change that for any given Virtual Server based on the domain name or even per-directory.

And you can always manually specify the PHP version by naming your file extensions either .php4 or .php5.
-Eric