Virtualmin 7 installer beta released

@Ilia - I used my trusty Wordpress migration plugin to see what would happen and it migrated the site flawlessly. (MySQL to MariaDB)

Excellent job, guys! I’ll wait for the green light on it to be finalized before redoing them all.

I’ve tried re-installing RC8 twice on the same Vultr VPS that was working with RC8 and now I’m getting the MySQL error that I previously had with RC7. [ sh: /etc/rc.d/init.d/mysqld: No such file or directory ]
Intermittent errors are the worst.

Those are the wrong repos.

Virtualmin 7 has its own repos.

And, you should never enable the Webmin repos for a Virtualmin system. We provide Webmin, often in a different version than is in the Webmin repos.

1 Like

Again, if you got Virtualmin/Webmin installed when you ran the install script, it definitely setup the Virtualmin repository. There is no other way to get our software installed. We literally use apt-get to install Virtualmin.

If the Virtualmin repo (/etc/apt/sources.list.d/virtualmin.list) doesn’t exist at the end (I’m sure it does, though), it’s nothing to do with the install script.

Can everyone start new topics for each new problem you find, please? This one is getting messy.

(We know about the Almalinux Mariadb path problem, we just can’t reproduce it. And, I think I’ve addressed everything else brought up in the thread so far. So, just new topics for new problems.)

This issue with Vultr, for now can be fixed by running ufw disable on Ubuntu 22.04, prior running Virtualmin installation.

We can. I messed it up when calling AlmaLinux, as that, rather than AlmaLinux Linux. I have checked in a fix just now and locally built a new Webmin 1.995 and it works fine now. Note, that MariaDB config is not only config that was affected, there were many other – Apache, BIND, ProFTPd). What concerns me is that you said you didn’t see that issue on Vultr AlmaLiunx? Was that an upgrade from Webmin 1.991 to 1.994? If so, then it would have explained it, otherwise I will need to spin up Vultr AlmaLinux instance myself to see how it goes.

It is surely not our issue. The packages updates are no longer compared against static hardcoded version numbers and dynamically queried from here. This data is cached and can only be queried once a day (or so).

Whatever OP is seeing, is a stale repo metadata cache. For anyone seeing this issue, make sure that your data/time is synced by running systemctl restart chronyd (on RHEL 8/9 systems) and then running dnf clean all.

Yes. I had 1.991 in the new unified repo (and 1.994 in the previous vm/7 universal repo). Not sure I understand why OS detection changes were needed, if it worked before?

That is absolutely not the right solution. The source of truth about installed versions is the package manager. Not a list of packages on the website.

Yes, agreed but as long as the user has repos for the package manager configured correctly.

I will improve that functionality to be less confusing for the user.


Happy to report a flawless install on a dedicated baremetal Debian 11 server, I even added PHP8.1, at some point I wondered if I was using the new installer and wondered how to check that ! Well, as stated in the documentation, VM6 installer will fail on Debian 11 so I guess I used the new VM7 installer :slight_smile:

Seems like awscli is already installed, nice. Backblaze available as a pro feature, nice…

Great job, thanks a lot for all the work done by Joe and Ilia (and others I don’t know) !



Hello, at first - great job fellows! At second - may I ask a question. If I install virtualmin as beta installer, will it automatically update itself when everything is ready for debian 11?
And also another question - is it possible to work with mysql, instead of MariaDB, or it doesn’t matter at all. I don’t know the differences …

Thanks in advice! Go ahead.

That isn’t known. It’s unlikely there will be changes that require human intervention, but we’re not calling it stable because things may still change (the RHEL/Alma/Rocky repos changed their structure a few days ago in breaking ways, for example).

Start new topics for new questions, but this question (mostly in reverse, going from MySQL to Mariadb) has come up many times in the forums. Search for it. It is possible and relatively easy (though not recommended…unless you have a damned good reason to change, don’t make your life difficult, the two databases are nearly identical from a user perspective).

1 Like

Postfix error after fresh install on a VPS. I didn’t change the Postfix configuration.

Jun 7 06:59:18 pop postfix/local[7271]: 54217137790:,, relay=local, delay=0.4, delays=0.37/0.01/0/0.02, dsn=5.3.0, status=bounced (Command died with status 127: “/usr/bin/procmail-wrapper -o -a $DOMAIN -d $LOGNAME”. Command output: sh: 1: /usr/bin/procmail-wrapper: not found )

But /usr/bin/procmail-wrapper is there.

This happens when an email is sent to a user.

I used downloaded 6-Jun-22.

Ubuntu Linux 22.04
Webmin version 1.994

Usermin version 1.840
Virtualmin version 7.1-1

Authentic theme version 19.93.1

Kernel and CPU Linux 5.15.0-35-generic on x86_64

Processor information Intel(R) Xeon(R) CPU E5-2680 v2 @ 2.80GHz, 4 cores

There were no errors reported after the install. I did notice that Postfix was the only server not running so I started it.

I’m not a pro so I can’t do much troubleshooting but this may be something in the install script so I’m reporting it.

Thank you for your tremendous efforts!


Just to make sure and to get your advice. I installed a new server with Debian 11 using the beta installer, all seems to be ok so far.
Once the install is done and everything works what is your advice:

  • wait for a final update of installer and reinstall both OS and Virtualmin
  • wait for a final update of installer and just re-run installer (if that’s possible ?)
  • doesn’t matter, if install was successful server can be used and virtualhosts started immediately, no need to reinstall OS nor Virtualmin …

This completes @netrica question, in fact it just points my own lacking knowledge, I thought that the installer ran once and then, once everything was installed the virtualmin-server took over as far as updates (and managing the server of course) were concerned … not re-installing would mean maybe discovering something missing 2 months from now and being forced to re-install everything from scratch to re-run the stable installer … ?


1 Like

Please start a new topic for new issues.

1 Like

Virtualmin has nothing to do with your filesystem.

Please start new topics for new issues.

1 Like

Thanks, will do.

I installed the beta on a fresh install of Ubuntu 22.04, with no GUI. I should have edited the shell script to include my pro key/serial. Other than not being able to use the professional features, it works flawless on Ubuntu 22.04. (Cannot update to professional as there are no repositories for VM 7 yet?)

The repository ‘ virtualmin Release’ does not have a Release file.

1 Like

That repo path should either include pro or gpl at the end, e.g.:

or (only accessible with serial number/key):

Did the install script generate the wrong URL, I guess?

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.

@hasse_basse1 Please don’t create offtopics! This question should be asked here.

If you are a Pro user, after downloading beta version of script to a fresh instance of Debian 11, before running it, edit it replacing GPL with your actual license/key information.

1 Like