Virtualmin 7.7 on Alma Linux 9.2 release update

OS type and version ALMA LINUX 9.1
Webmin version 2021
Virtualmin version 7.7
Related packages SUGGESTED

hello! i have upgraded to Alma linux 9.1. I have upgraded to 9.2 release and the system crashed, I tried to do a restore in a clean installation of alma 9.2 without success. Any idea of the problem? Alma Linux 9.2 RELEASE is not yet compatible with virtualmin 7.7?

Can you please provide any detail? A ‘dot’ or ‘point’ release shouldn’t be radically different. Mostly bug fixes, etc. I think.

Seems you lost a hard drive partition when you upgraded. This has something to do with what happened going from Alma 9.1 > 9.2 as far as I can tell. The system isn’t even able to get to the point of loading anything because it sees a missing partition. I think this is ALL Alama.

Any reason you didn’t try the diagnostic suggestions given?

I have tried but without success. Only kernel panic.
So luckily I had backup and went back to version 9.1. And as I told you, I tried to restore to a clean one with release 9.2 and it gives installation error.

Of course it is.

Whatever problem you’re having is not related to Virtualmin.

We don’t provide the kernel or the bootloader, and we didn’t configure your file system table. This looks like a problem with either the volume, or the label on the volume, since the disk can’t seem to be found.

You’ll need to troubleshoot why that is (but, again, has nothing to do with Virtualmin, this is all low-level stuff we don’t have anything to do with). dmesg is where I’d look first, to see what disks are detected during boot (if any). pvscan not showing any seems alarming, and makes me think something changed in VirtualBox or your configuration for it.

Hi Joe, nice to greet you. I don’t blame anyone for the problem, I just found it strange that I tried virtualmin 7.7 on a clean install of Alma Linux 9.2 with no success. Apparently the Alma Linux team, or in a better case, Red Hat, screwed up the release.

That’s not what your post is about though? If you have trouble installing Virtualmin on a freshly installed Alma 9.2, we’d like to know about it, and see the errors or a description of the problem you’re having (in a new topic, unless the problem on a fresh install is the same boot failure as this topic, but I can’t imagine that’s the case).

Try Rocky 9.2 if you can. I’ve never had a issue, but I’m not using virtualbox either.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.