Virtualmin 3.91.gpl Update - IP address removed?

Hi,

I did the update to the new Virtualmin 3.91.gpl on my CentOS 6 server today.

After creating and removing some servers I noticed that my Sites on a secondary IP could no longer be reached.

After a few minutes of finding nothing in the logs I restarted the server, some of the sites came back up - but not the default site for the IP. I then tried to access the site via IP and that did not work ether, I finally went to check the networking settings and noticed that eth0:0 was now removed!!!

I then also found that - /etc/sysconfig/network-scripts/ifcfg-eth0:0 - was removed, something that was working fine for a long time and was never removed even with many reboots. After adding the file back again, the storm calmed and all returned to normal.

I saw that their are some IP related updates in this update and wondered if this could have had any effect on this??

Thanks for looking at this!

Howdy,

Hmm, I hadn’t heard of a Virtualmin upgrade dropping an IP before.

However, I did ask Jamie to see if he has any thoughts on all that, we’ll see what he has to say about that :slight_smile:

-Eric

Thanks so much for looking into this!

No problem!

The bad news, though, is that we haven’t been able to come up with a case where that might occur during an installation.

In theory, the only Virtualmin function that should be able to cause that is to remove a domain using a private IP address, or turning off the private IP for a domain.

We’ll keep an eye out for any other problems in this regard, but we haven’t been able to reproduce that.

-Eric

Eric,

Thanks! I will let you know if it does happen again! But I think it might have just been a one off thing that messed up something!

Thanks!