Virtualmin 3.73 to 3.74 Upgrade Problem

Running 3.73 GPL installed via the file (started with 3.70 I think), I try to keep the server up to date using the automated update settings, but been having problems with updates not showing up.

For example when Centos 5.4 was released recently it didn’t show up at first, even tried running yum ugrade with no effect (I checked the Centos repository yum/virualmin connected to and 5.4 was there).

Had to hit the Refresh Packages button before anything listed and then well over 100 new updates apeared including Centos 5.4. Before using the Refresh Packages button (that was the firt time I’d used it) I’d get the odd upgrade listed (which I’d always install), so it was partially working, but based on the Centos 5.4 problem it wasn’t working 100%.

So when checking updates now I hit the refresh packages button just in case and so far no option to upgrade to Virtualmin 3.74.

Currently everything listed as available for upgrade via virtualmin is ugraded, I recently installed the Webmin Linux firewall module and right away there was 2 new updates relating to IPtables, so it would appear to be partially working.

I know I could upgrade to 3.74 via Webmin, but on another server Webmin was installed first and this caused no end of upgrade problems, so don’t want to change from Virtualmin upgrading virtualmin.

Any ideas?

David Law

I think this is a bug.

Perhaps, Joe or Jamie can shed some light on the topic.

3.74 is still not showing up as available via Virtualmin.

Will use Webmin to upgrade when I get some time free.

David Law

3.74 showed up just now.

Updated it fine.

David Law