Virtual Servers list shows only the last domain/account I modified [BUG] ?!

Hello everybody, here is my story:
I migrated several account successfully from cPanel but I have an issue that never happened before…

On my left dropdown or /virtual-server/ summary list will only appear one domain name from the 15 accounts, the last modified. I’m logged in with root. I tried some login, logout, clear cache, etc.

I cannot add or edit other domains/accounts because I can’t select them else everything runs fine.

Please advise,


Hmm, I seem to vaguely recall that Virtualmin keeps a kind of cache for these things. I think it was in a different context, but it might help to empty out the directory /etc/webmin/virtual-server/links-cache and restarting Webmin. (Maybe make a copy of those files elsewhere first in case they’re important, which I don’t think they are.)

I tried but still it’s like impersonating the last account and when I hit create I get:

No parent Virtualmin server for the user root was found!

Luckily I had access to Webmin Users so I have edited another account giving all privileges and add it to sudoers list. So, now I will login with that su user instead of root. I would like to mention that you can restrict the ip for each account individually, which is a nice feature.

Thanks for the heads up – I’ve asked Jamie if he could take a peek at this thread.


Did one of the migrated domains perhaps have a username in cPanel that clashes with an existing Virtualmin login? I can imagine this happening if the domain’s username was root for example.

Sorry for delay… No it was a ordinary username.

Anyway to continue, with the su account, I have deleted root from the users list and re-add it and now I can use root also if I want.

Best regards,