Virtual Server shows website Top Server

Hi,

I’ve installed Virtualmin from the install script on Ubuntu 12.04.

I’ve managed to create my first virtual server with a website on it.

But when I create my second virtual server and change the A-record on the domain to point to the correct ip address it show my 1st website not the one in /home/user2/public_html/…

Seems like something is wrong with virtualhost i suppose.

This command grep -i ‘<virtualhost’ /etc/apache2/sites-enabled/* (found on this forum) outputs:

/etc/apache2/sites-enabled/000-default:<VirtualHost *:80>
/etc/apache2/sites-enabled/concept-it.be.conf:<VirtualHost 91.233.105.41:80>
/etc/apache2/sites-enabled/optiekmeulemeester.be.conf:<VirtualHost 91.233.105.41:80>

So i can see my second website.

Could someone help me find this out please.

thanks!

Howdy,

Are you by chance using NAT? If you’re using NAT, but Virtualmin isn’t configured to set that up properly, that could cause the issue you’re seeing.

If you go into System Settings -> Re-Check Config, does it detect any errors?

-Eric

Hi,

In the config check I do get the following:

Virtualmin could not work out the default IPv6 address for virtual servers on your system. You will need to update either the Network interface for virtual addresses or Default virtual server IP address fields on the module configuration page.

I don’t understand what needs to be changed on the module configuration page?

Thanks for your help!

Found it. I forgot to create a ServerAlias for test.example.com wich was my a-record pointing to the new server.

Sorry for the overload :).