Virtual Server: Apache LogLevel bug

All virtual servers have LogLevel set to “emergency” (seem to be the default), but I noticed there are still “info” messages in the log for one virtual server. This server is “Default website for IP address”

If I change the loglevel for the "default server (/var/www/html …) the info messages disappear. Is that the expected behavior? The /var/www/html server LogLevel overrides the virtual server setting?

Hrm, what LogLevel are you referring to exactly… one in the Apache VirtualHost blocks?

If so, I’ve never seen that set before. Typically, the amount of messages produced by Apache without that set is plenty for debugging day to day issues that come up.

My vote would be to disable any LogLevel settings in the VirtualHost blocks, as it sounds like doing so has the desired behavior anyhow :slight_smile:


Correct, Apache. The loglevel settings are all set to emergency (which is apparently the virtualmin default). Only the “default server /var/www/html” is set to a lower level. Unfortunately this one seens to override the other loglevel. Again I know to fix that, but I wanted to mention it here. Probably most user don’t even notice that.

Apache. The loglevel settings are all set to emergency (which is apparently the virtualmin default)

Well, Virtualmin never sets a LogLevel :slight_smile:

The default VirtualHost block Virtualmin uses never touches that; there’s generally not a need to since the default of not specifying one is typically perfect for most setups.

If you’re seeing the LogLevel being set somewhere, then somehow that got enabled outside of Virtualmin.

Virtualmin doesn’t setup a domain that uses /var/www/html, so it’s possible that’s the culprit. Somehow, a LogLevel setting was added in there that’s causing other entries to be overridden.

I’m a bit surprised that all the VirtualHosts are inheriting the setting from that one default domain there though… I’d have figured the VirtualHosts would inherit from the main Apache settings, with the option of each being overridden by setting the LogLevel locally within that block. So that strikes me as odd, but I’m glad you figured it out! :slight_smile:


There is a default server in Apache. You can see it in the Apache module

Default Server 	Any 	Any 	Automatic 	/var/www/html

Also if you click on any domain there and then on “log files”. You can see that the loglevel shows “emergencies”.

But there is not loglevel set in the config file for that server. So the loglevel of the default server is taken apparently?

It is probably only a a limitation of the GPL version? Which you don’t use of course :slight_smile:

I changed the title of my original to bug, because now I am certain that this is a bug. The config file and the log level displayed in the “log files” module should be in sync. But they are not.