Virtual Server Admin can change Server Template


It appears that a virtual server admin can login and change the server template that their account is using. I don’t like the sound of this and don’t particularly know if / what the implications are / if it actually works. Is there a way of disabling this? The Account Plan is shown as just text whereas server template is shown as a drop down list. I would prefer the template to shown as just text also.

I also noticed it looks like they can change the ip address that they are on. I’ve seen under account plans there is a setting that controls this, but how can I change the default thus change all account plans rather than change each individual account plan?

Under Account Plans -> Allowed Capabilities I have it set to “Automatic, based on other limits” but I have so far not been able to work out how to change any of them without customising each account plan.

Many Thanks


I’m just stumbling over this here too.

I’m planning to offer a “slave nameserver” service, where customers can set up their domains on my system as a slave DNS zone, using the “Slave DNS” plugin.

For that, I created a special Template with required settings. It’d be nice if I could set in an Account Plan that the users of this service (which I assign to that Plan) can NOT change the template, and have to use a specific template for servers they create.

Would become a big mess if they can use a template as they please, cause the Slave DNS thing will possibly not work correctly then.

Hi Locutus,

Have you found a solution to this yet as I have not.
Is there anyone that can help here please?

I have found the option to disable the “edit virtual server” page but this also hides the change password and contact email sections which I would like to keep visible and edittable.




No solution yet. I posted an official feature request and the Virtualmin developers are working on it now.

Ooo sounds good!

Link to the request here:

and a snippet that sorta fixes the problem (for the time being at least)

Hmm, well, there’s one option now that may be close to what you’re looking for…

If you go into System Settings -> Server Config -> TEMPLATE_NAME, one of the options on that screen is that you can set “For use by”, where you can uncheck “Server Owners”.