Very stupid question SORRY

SYSTEM INFORMATION
OS type and version Ubuntu/20.04
Webmin version 1.994
Virtualmin version 7.1-1Pro
Related packages SUGGESTED

I have created a play site, something to learn on and not exposed to internet, just for local network use how do I get to it, the link given after the install script does not run, I had installed it at the top level

I also get this error when trying to install wordpress

image

Keith

In my situation my play (or development) sites are sometimes on machines on the same subnet as my workstation. When that’s the case, I put an entry into my hosts file (found at C:\Windows\system32\drivers\etc\hosts) on my Windows 10 workstation that points the web name to the IP address of the box the play (or development) site is on (like 192.x.x.x or whatever).

In your edited post I see that the email address is missing the top level domain.

When I set up sites I get some of the same warnings, but they don’t stop the site from being set up. I thought there might be an issue on the server but see you are getting some of the same indications (“not available in repos”):

Checking PHP modules ..
Installing recommended PHP pecl-ssh2 module ..
.. not available in repos
Installing recommended PHP pecl-imagick module ..
.. not available in repos
.. checking done
Configuring webserver PHP settings ..
.. done
Restarting PHP-FPM server ..
.. done
Applying web server configuration ..
.. done
Now installing WordPress version 6.0.1 ..

Hope that’s helpful,
Charles

Hey nothing is stupid here, do not feel sorry or need to apologize for post, this community is to help you with this issue’s. Did you trying to install wp manually? Any errors?

The error in your screenshot says something about the email address being invalid. Virtualmin generates that email address from the domain name of the virtual server.

Perhaps you entered the domain name incorrectly (and quite deliberately so for your play site) when you created the virtual server - you may have entered the domain name as thebloggerspot without the extension where the real name of the domain should be thebloggerspot.com or something. Know that Virtualmin is flexible enough to let an admin create a virtual server and give it a domain name sans extension, but the WordPress install trips up on this.

The best way forward for you would be to delete the virtual server and start over again from square one by creating a new virtual server. Be sure to enter the domain name correctly this time around or if you must choose a fictitious domain name, give it a fictitious extension as well so that the fictitious domain name is RFC compliant.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.