Very important. Hide "Change Password"

Hi there,

this is very important. I finally need to remove, to hide or to disable the menu entry “Change Password” in the User Panel. I’m happy about every single hint.

Thank you.

Howdy,

You can do that by going into System Settings -> Module Config -> Administrator’s Webmin Modules, and you can unselect the ones you don’t want your users to have access to.

-Eric

Under Module Config I don’t have a Administrator’s Webmin Modules entry. Mine is under Server Templates > Default Templates and I have already selected “No” for Change Password. But the menu entry is still there.

Which version of Virtualmin are you using?

-Eric

Im using 3.71 GPL

Hmm, I’ll check into that and get back with you shortly :slight_smile:

-Eric

This looks like a small Virtualmin bug - the change to allowed modules isn’t being applied to existing users, only new ones.

The fix is to SSH in and run the command :

for dom in `virtualmin list-domains --with-feature webmin --name-only`; do virtualmin modify-domain --domain $dom done

I will fix this properly in Virtualmin 3.72.

Thank you for the solution, but where and how should I run the SSh on Virtualmin to run this command properly? How can I ran this command?

Howdy,

SSH is a mechanism of connecting to a Linux Server.

So, along the lines of how you can use “FTP” to connect to a server, you’d need an SSH client.

If you’re using a Windows machine, you can use an SSH client such as Putty:

http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html

And then log in as root to your server from within Putty, and from there you can execute the commands Jamie gave you.

-Eric

That step with putty is clear to me, but when i paste the code in the shell i get the following:

http://www.abload.de/image.php?img=untitledluao.jpg

Hrm, looks like the forum mangled the code that Jamie entered.

I put a copy of it over here on Pastie, this one should be correct:

http://pastie.org/private/eqnkdgkvsccjpqltwwflkq

To bad, the change password entry it still there :frowning:

Alternately, you can wait for the 3.72 release of Virtualmin, due out in a day or so.

As a work-around till then, you can go to Webmin -> Webmin Users -> domain-owner , and remove his access to the Change Language and Theme module.

Are you seeing this “Change Password” link in Usermin on port 20000, or Virtualmin on port 10000 ?

On Virtualmin port 10000. And the Workaround also did not worked, because Change Lanuage and Theme is already deactivated. I think I’ll have to wait for 3.72.

EDT:

Now updated to Virtualmin 3.72 and Framed Theme 7.4 but the Change Password Entry is still there ;-(

Sorry, I made a mistake … I didn’t realize which “Change Password” link you were referring to.

If you mean the one on the left menu down the bottom that is visible to virtual server owners, at the moment there is no way to remove this, sorry. I am curious as to why you would want to though?

Because we have a very complex server system, with a lot of logins and we get feedback that it would be easier that users are not allowed to change password.

I checked the file edit_passwd.pl. It seems to be the file responsible for “Change Password”. Is there at least a way to add the a custom output? (By editing the edit_passwd.pl) Ex. “Chaange password currently disabled”

I will add an option to prevent password changing in the next Virtualmin release, on the Edit Owner Limits and plans pages.

Till then, you could manually edit edit_pass.cgi and after :

require ‘./virtual-server-lib.pl’;

Add the line :

error(“Password changing currently disabled”);

Thank you, I’m looking forward to the next release.

You actually have clients who think that changing there passwords is a bad thing ? Frankly I think that is a very bad idea on the security side, in fact if I was forced not to be allowed to change my passwords when I wanted to I wouldn’t around long.