Validation failed when adding a user with ftp access

Hi,

i have added a user on a domain with FTP access to a sub directory of the website.
It works correctly but now i have a validation Failed message which says :

Mail for domain : Home directory /home/xxx/public_html/photos for user john.xxx is owned by group 513

What should i do ? can i change the owner of this folder ?
i have created other ftp account with access to the root folder of my domain and i never had this message

Thanks

Howdy,

Normally, when you’d want an FTP user to have access to the public_html folder, you’d want to go into Edit Users, and choose “Add a website FTP access user.” on the right.

That would setup a user with permissions for being able to write to the public_html folder. Also, those types of users can’t do email… otherwise, their email folder would show up in the middle of your public_html directory.

-Eric

Hello,

well, i have used the “Add a website FTP access user”, yes

using email adress=john
Home Directory = website subdirectory “photos”
but the login permission only shows me “Email and FTP”, so i have chosen that

After the creation, in the list of users, this user has only “Login access=FTP”, databases = No, DAV=Yes

This user can connect to ftp directly in the /photos directory, that’s great but only the validation doesn’t work

What have i done wrongly ?

If you go into Edit Users, and click the name “john”, and then go into Email Settings – is there an option named “Primary email address enabled”?

-Eric

Hello Eric,

no, in Email Settings, i have only “Send updated account email to :” and “Last email login : No logins recorded yet”