Using fcgid for php

I noticed that using fcgid for php execution seems to be coming up as the default now so I gave it a try. I kept getting 500 errors, with "premature end of script headers" in the error_log.

After some experimentation I found that I needed to edit the apache virtual host FCGIWrapper directives to use the php4.fcgi located in the public_html dir instead of the one in the ~/fgci-bin dir, and I also needed to edit that file to exec php-cgi instead of php. (And also install the php-cgi package of course.)

Is this a known bug?

Oops, I take that back. I tried again with a new virtual server and this time it works with the script in ~/fcgi-bin and the generated script is already using php-cgi. I guess having the php-cgi package installed influences how that script is generated. If so then the bug is really that it’s not detecting that the php-cgi package isn’t installed…

This is on Ubuntu.

Fllowing up on this, I’m migrating a few projects from cPanel and Plesk to VMPro (yah…)

On cPanel it used the older phpsuexec, and on Plesk I’d always need to compile in suPHP and get that working porperly.

Does VMPro come with, or have a facility to get that suPHP or php-cgi functionality working easily?

Hey Vance,

For suexec PHP options Virtualmin handles PHP as CGI or running under fcgid. It can also configure mod_php, but we recommend using fcgid (it’s safer, and avoids a lot of permissions issues that come up when running under mod_php).

We provide the necessary packages on all supported platforms, so you shouldn’t have to build anything. Just let us know if any problems pop up when using fcgid. It’s still pretty new, but it seems to be shaping up pretty well lately (I switched our development website over to it a few weeks ago and it’s been working fine).