Users are created twice - with dash instead of 'at' sign (@)

Hello,

when creating a user, the system creates 2 users in the /etc/passwd file, when both are identical, except of having a dash instead of an ‘at’ sign.

Example:
user@domain.com:x:555:500:Someone:/home/users/user:/dev/null
user-domain.com:x:555:500:Someone:/home/users/user:/dev/null

This is a very odd behavior, that started a while ago (older users are proper).

Another side effect, was that some of the aliases that were directing to proper addresses, changed to direct to the 2nd user. This was MOST troubling to find out.

Does anyone have any clue as for the possible reason for such behavior?

Thanks!

Howdy,

That’s actually intentional.

Postfix doesn’t support using users with a “@” sign in their username.

Virtualmin is working around that problem by creating a second user with the same UID/GID.

There’s some additional details on that in the article here titled “What’s the deal with @ in mailbox usernames”:

http://www.virtualmin.com/documentation/email/faq

I for one would be interested in the users being checked from a MySQL database instead.

Two of my reasons for this are:
(1) because of any potential maximum length issues for usernames in the chosen Operating System.
(2) because I would rather the users not exist directly in the OS.
(3) because I do not want to use and have to deal with LDAP (though I have been starting to consider this as an option – time permitting).