Username vs Email address

Is there a way to use the full email address including the .com or .co.uk etc as the username rather than the name.domain or name@domain

This is a general annoyance and seems to confuse everyone that I have given email accounts to.

Thanks

Howdy,

You can change the username format by going into System Settings -> Server Template -> Default -> Mail for Domain, and change “Format for usernames that include domain” to “user@domain”.

-Eric

I found the template that allows you to change the format but what I really want is the standard format of “user@domain.extension”

Anyway of forcing this or tweeking virtualmin/usermin into using this format?

The user@domain format actually does refer to using the full email address… it would look like “user@domain.tld”.

-Eric

Well that’s good to know but is confusing. From an user experience point of view changing “user@domain” to “user@domain.tld” would sense.

Anyway, tried it and it works.
Thanks

Actually, “domain” in that context refers to whatever is configured in System Settings ->Virtualmin Configuration -> Default for new domains : Domain name style in username. So it actually can be just (a part of) the domain name. :slight_smile:

This option determines whether the domain name used in usernames that contain the domain will be the full domain name, i.e. “virtualmin.com”, just the first part, i.e. “virtualmin”, or the user/group name for the domain. By default, the group name is used for new top-level servers, and the first part of the domain is used for sub-servers.

If I changed to username to username@domain in virtualmin configuration, will it affect existing users and domains ?

To modify the email users of existing domains, you need to use the function Server Configuration -> Change Domain Name : Change mailbox name suffix. The functions that Eric and me mentioned only apply to new domains/users.

I did a test on existing domains of local development machine. I tried put username (without domain) under Server Configuration -> Change Domain Name : Change mailbox name suffix, but the email users still retain it’s original username@domain

I don’t fully get what you are / have been trying to do there. Your second screenshot implies the email account suffix was already set to “username” before you changed it?

You cannot (as far as I know) use this method to remove the suffix, only to change it. What exactly are you trying to achieve?

Eric, is this still (2017) found in the same location? I can not find it.

Thanking you.

I know this is really old … but where can I find this option now: Server Configuration -> Change Domain Name : Change mailbox name suffix.

It no longer exists in the newer version of VM. I would like to update all EXISTING users to use the new user@domain style, from the old user.domain style.