Username for new Virtual Server

Here is my settings:

Include domain name in usernames: Always

Domain name style in username: First part of domain

When I’m creating a new Virtual Server with this domain: ‘’ the server are creating a user/group with ‘’ but I want the user/group just with ‘example’, because the mail setup are like this: ‘’ and no just ‘’

What I’m doing wrong here?


I don’t like to double post…but I don’t get any answer here, and I solved my problem and glad to share the solution here if anyone will have this problem in the future too…my solution was let the settings like the default of virtualmin (don’t change), like that:

Virtualmin Configuration -> Default for new domains
Include domain name in usernames? -> Always
Domain name style in username -> Username or first part of domain