Usermin/Virtualmin/Webmin(?) not accepting incoming mails

OS type and version REQUIRED

Mac OS 12.5 on client
Ubuntu 20.04.5

| Virtualmin version | REQUIRED |
Virtualmin 2.001


I am slowly getting around to rebuilding all the items on the server and have just installed a test virtual server and cannot get the email to work through usermin. I then checked the main server installation (whose email I had not tested) and it has the same problem.

I have read the installation guides, FAQs and Troubleshooting sections but none them have helped me identify the problem.

I can log in to Usermin fine. Prepare and send an email and it is received at my iCloud account (using my apple mail client on the Mac). However I cannot send a reply or rather a reply is not being received. they are leaving my Mac but then disappearing. I have looked at the suggested logs but there is nothing there that indicates my message has been received by the server. DNS all looks fine.

Internal messages are getting through as a faulty address generated a message from the Mailer-Daemon that was successfully received. So it appears to be at the entry to the server. Firewall ports are open so not is not that. I am stumped!


While trying to set up the above I set up an email address in the address book using @ in the Real name ( Usermin interpreted this as two separate email addresses so when I inserted the address into the email from the address book, it looked correct. However, after sending, I looked at the email again and it had sent emails to both my proper email address as in the address book but also tried to email Hence the Mailer Daemon message. Tried it on two separate accounts so it is reproducible. Ilya might want to look at it? If you need screenshots, let me know.



Have you checked your mail log? This holds the key to many issues related to email.

*** One-on-One Session with Trusted, Professional Virtualmin and Technical Expert ***

Yes. I checked all logs and there are no entries (other than criminals trying to hack the server). My emails at the times I sent them are just not there which is why I assumed it must be an interface issue on the inbound side.



I sent you a message on WhatsApp. If you have a moment, let’s chat.


Thanks for the offer.

I did not realise my contact details were in the reply. My WhatsApp is restricted to personal issues only so I prefer (also for others to benefit) to conduct all communications via the forum.



This topic requires a bit more back and fourth discussion then I can offer in the forums at this time. Both because my time is limited today, and because there are lots of moving parts so to speak regarding this topic.

Perhaps someone else who has time to continue the back and fourth diagnostics will be able to take over. I was aiming to find you a solution with the little time I had, however my available time has expired as I must prepare to leave for the day.

Cheers and good luck!

Then nothing is talking to the server. Your DNS is wrong, or the necessary connectivity isn’t there (maybe port 25 is blocked by your ISP).

Even failed connections will result in log entries. If you don’t see them, then there’s not even an attempt happening, which means the problem is not mail server configuration, but rather at some earlier part of the process.

just like @Joe, i would guess DNS (missing MX?) or blocked network port someplace, but without a domain/logs to check, can’t help.
try an online tool for checking your mail server. if there are errors you can’t understand/check/fix post them here for additional help.


Yes 25 is blocked but I thought that was for pop only? If I am using IMAP is 25 still needed? I will organise to get it opened in any case to try.

Thanks Joe,

It was indeed port 25 giving the problem. Now open and functioning properly. Dmitrist, thanks also the dns records are fine and as you can see it is now working properly.


25 is SMTP. Other mail servers send mail to your server on port 25. If you don’t have port 25 incoming, you can’t operate a mail server. For outgoing, you can work around it by subscribing to a mail relay service like Mailjet or Sendgrid or whatever. But, for a fully functional mail server that both sends to and receives from other mail servers, you need port 25.

Thanks Joe. That is clear. As I said opening it has made everything work.


This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.