usermin password recovery

seems like a newbie question…but im a couple months into virtualmin and i cant figure it out either.


so no one knows how a user is supposed to recover their password?

I didn’t even know Usermin had password reset functionality! But, I guess it does, if you have the Virtualmin Password Recovery module. You may need to install it, if you don’t have it, already.

You can do that on CentOS with:

# yum install wbm-virtualmin-password-recovery

Or Debian/Ubuntu:

# apt-get install webmin-virtualmin-password-recovery

After installing it you should see a “Forgot your Usermin password?” link on the Usermin login page, which works the same as it does for Webmin/Virtualmin.

looks like im no longer stuck in moderation purgatory…but what happened to my pending replies?

Doesn’t work for me, and:

# apt-get install webmin-virtualmin-password-recovery Reading package lists... Done Building dependency tree Reading state information... Done webmin-virtualmin-password-recovery is already the newest version.

No “Forgot your Usermin password?” appears.

It works for me. Once I installed the virtualmin-password-recovery module, I get a “Password recovery” button on the login page for Usermin (and Webmin), with no other changes; I didn’t need to enable it, it just started showing up (though users would have to have their password recovery email set in order for it to actually do something useful). Looks like this:

Screenshot of password recovery module

What OS and version are you using? That shouldn’t make a difference, but I assume there must be something broken on some system, because it causes so much confusion and I’ve never been able to make it not Just Work when I installed it.

Debian 8 and Virtualmin GPL.

I’m pretty sure it is the GPL version that isn’t up to snuff, as I said in this request for support:

It works on a system I have running Virtualmin Pro.

Here are the GPL Virtualmin system versions:

Operating system Debian Linux 8
Webmin version 1.844
Usermin version 1.711
Virtualmin version 5.99
Theme version Authentic Theme 18.49-8

Just out of curiosity I tried on mine - Centos 7 with GPL version

As soon as I installed it

yum install wbm-virtualmin-password-recovery

The button appeared on my login just like Joe’s image. It doesn’t do anthing so I will have to figure out how it is supposed to work now.

@Joe - how do you insert an image in the post

Actually it does try to access:

But I get a Server Not Found error

EDIT: it is redirecting to (the FQDN of the server) and I get the Error page

If I change this to it goes to the proper page.

If I just use

It goes to an adminstrators page for setting the recovery email (Customize Recovery Email)

We use markdown in the forum, so the usual markdown syntax like this works:

![Alt text](http://imageurl)

I usually host my images at imgur, just because I already have an account there and it’s reasonable easy. Attachments directly in Drupal are possible but clumsy as hell, so we don’t really use that feature. I’d like to get us onto a forum with nicer image capabilities eventually (among other nicer things), but it’ll be a while as migrations are a serious pain.

I’ve hunted around and can’t figure out how to change the Password Recovery button to link to instead of

I expect it is something really simple but I can’t seem to locate why it is using (system hostname) instead of and why goes to a different page than

If anyone can point me in the right direction I would appreciate it.

You should make sure the FQDN of the server is resolving for the world. There are some other subtle problems that can pop up if it doesn’t. Usermin should probably direct to whatever domain was in your URL bar for the Usermin login page, so that might be a minor bug-like in the password recovery module, too.

Thanks for the info Joe.

I just checked a Webmin password Recovery link and the recovery button works fine and directs to
The page is a Virtualmin Password recovery page.

I assume this is not the page that would be used for Usermin password Recovery as it does not look like something that regular users would feel comfortable with and requests a Virtualmin administration login or Virtualmin Domian Name. So I assume that the page I am looking at is only for administrators.

I have added DNS records for the server’s FQDN and waited for it to resolve.

It now all appears to be working as expected. It is displaying a password recovery page for Usermin Password recovery.

The full link is: https://ServerHostName:Webminport/virtualmin-password-recovery/usermin.cgi

This should then be the same for all virtualhosts on the server. Thanks for letting me know that the FQDN needed to be set up in my DNS.

Thanks again for you help.

PS. Now the Password Recovery form just has to be reworked to look more like the login form.

To follow up on this, I’m pretty sure it was just an older version of the module getting installed. I’ve re-added the new version to the Debian/Ubuntu repos (where it got removed from during a repo cleanup a few weeks ago). Anyone on Debian/Ubuntu who was having this problem, see if you can upgrade to 1.7 of the webmin-virtualmin-password-recovery module and see if it resolves it (old versions didn’t support Usermin).

E: Unable to locate package webmin-virtualmin-password-recovery

What am I doing wrong? I tried apt-get install webmin-virtualmin-password-recovery

Do you have the virtualmin-universal repository enabled?

How do I check that? I did just a standard installation. And I understood that that should be enough.