usermin imap error sending mail

One of my customers gets this error every time they try to send an email from usermin:

Failed to send mail : Failed to set IMAP flags : Error in IMAP command UID: Invalid arguments.

The mail is actually sent regardless of the error message.

Config: VMPro/webmin/usermin default setup - all current version on CentOS.

I’ve checked settings against accounts that do not show this error and cannot find any differences. Logs gave me no clue.

Anyone know what this is or how to fix it? Looks like one of those multi-hour research projects to solve myself. While I’ve love the thrillof solving my own problem, I’d much rather just get this fixed and spend my time solving other problems. <grin>

I did a search on the imap error before posting, and it didn’t show me a previous post on the same error. Sorry for the sort of double post.

But this one is different in that the user sees the error when they try to send a mail, not delete a folder. I’ll explore the ideas in the other thread to see if they help. (i.e. purge folder)<br><br>Post edited by: SteveAcup, at: 2008/02/17 09:48

OK… have a partial answer:

My default settings are for each usermin client to not save sent mail. Each client with default gets the error message. If a client changes their preference to "save sent mail" then the error message goes away.

Using default VMPro install/CentOS.

I’d like to keep the default to NOT “save sent mail”. Any suggestions?

Yes, I can carry on a conversation with myself.

Additional report:

When I change a user preference from -not save sent mail- to -save sent mail-, the error stops.

When I change the usermin defaults from users do not save sent mail to save send mail, the error still is stopped, but all users that have their preferences already set to not save mail still get the error.

If I turn off the ability of user to change that particular setting and lock them on -save sent mail-, then the error message returns.

I’ll file this in a bug report.