Usermin: "Deny Sender" not working with alias?

In Usermin it looks like “Deny Sender” works only on the direct email account and not on any Alias.

Is there a way to make it work for Alias emails too?

is there a workaround?


Jamie says that this shouldn’t actually matter – the “Deny Sender” button adds the sender to a SpamAssassin blacklist.

So whether the email is addresses to an alias, or a main account, shouldn’t actually matter.

Are you getting any kind of errors when this occurs? Or does it just not block the sender?


Hola, thanks for coming back!

No errors, it’s simply not blocking.


Hmm, you may be seeing an issue with how SpamAssassin is setup.

If you look in Email Messages -> Spam and Virus Scanning, what is “SpamAssassin client program” set to?

I suspect it’s currently set to “spamc (Client for SpamAssassin filter server spamd)”, which doesn’t suppose per-user configuration settings such as what Usermin sets up.

What you could do is set that to “spamassassin (Standalone program)”.

That setting does take a little more CPU… it may not be noticeable though unless you have a lot of incoming email, or a low-end server.


I am not sure, maybe the senders change email all the time.

A nice function would be blocking by domain, so I can simply delete all with as return domain address.