Usermin after Webmin 1.990 Upgrade

OS type and version Ubuntu Linux 20.04.4
Webmin version 1.990
Usermin version 1.834

I had recently reported that Usermin was throwing an error stating that Perl execution had failed after upgrading Webmin to 1.990.

Subsequently, I restarted Usermin and that solved the issue.

Can you include the exact error you got. I’m assuming some Webmin API changed or moved around, though I’m surprised that’d break Usermin, since Usermin is mostly independent of Webmin.


Undefined subroutine &WebminCore::getvar called at /usr/share/usermin/authentic-theme/ line 59.

Just remembered that I also did update Authentic Theme as well that came available after the Webmin upgrade. If that had a part to requiring a Usermin restart?

Yeah, that’s the source of trouble. I believe the Authentic updater updates for both Webmin and Usermin at the same time. getvar is a new function.

That’s a risk of updating Authentic ahead of Webmin or Usermin. I tend to recommend sticking with the packaged version unless there’s a bug specifically affecting you.

Problem is that the authentic theme said it was an update (after webmin update), most of us would have clicked on the update button thus the error. I am guessing we can downgrade theme or wait till theme bug fix been released.

@cyrus I downgraded theme and it made no difference. Had to clear browser and theme cache, thought it worked but it didnt. We will have to wait for an update of the webmin/theme combo.

A new Usermin update seems to have fixed this.

That should not be happening. @Ilia is Authentic still offering to update the theme outside of packages (and to versions that break)?

I strongly discourage updating anything outside of packages, including the theme.

1 Like

Theme upgrades will never be prompted, unless enabled by an admin or if the version of Webmin and/or Usermin is incompatible with a new theme release. It will not even be possible to install the theme update forcefully by using UI, if Webmin and/or Usermin versions are incompatible (by bypassing the warning, as it used to be in the past).

It must never be possible to update the theme using UI when there is an incompatibility found. Although, it would still be possible to do it using CLI.

Although, I was thinking that it’s not happening but doing a quick test confirmed that Usermin theme was upgraded as well (while shouldn’t have). Usermin compatibility check didn’t work because it seems that I have forgotten to update file. Which is fixed now.

This has been fixed in Authentic Theme 19.90.1. Thanks for reporting!

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.