Useradd for virtualmin when using SSH key and not root with password

SYSTEM INFORMATION
Rocky 9 REQUIRED
latest from script REQUIRED
latest from script REQUIRED
User account SUGGESTED

I was sure this would be an existing issue.
Just installed to Rocky and are only using SSH to login as root so we don’t have root password.
Please refer me to an article about how to add a user to manager the virtualmin GUI environment.
I am a pro user and don’t know where to add that information in the required information.

Please advise.

there is a command line for it Extra administrators – Virtualmin

Thank you for this reference. This is going to make all the difference. One more question.
If I type in the following command will this give me a global virtualmin admin to have access to manage the entire virtualmin environment, all virtual servers, and accounts?

// # virtualmin create-admin --name myadmin --pass mypassword --desc “my description here” --email “my admin email”

sorry I only know what on the doc, never done it.

I gave it a try and it didn’t work out. I tried logging in and I was not able to. Please see the following command I tried based on my understanding.

Just set a root password.

I hope your using SSH keys to login as root(so you can disable password login), I presumed that what you meant and you want someone else as a extra administrator.

Correct. I would like to keep root login unavailable. I would like to create a specific virtualmin admin

Sorry, missed you response, a close look at the command you added, you using inverted commas and that seems to be wrong, maybe the copy and paste did that, let me try in putty…don’t look like it is. Make sure you use --desc “my virtualmin admin” not --desc “my virtualmin admin” as the error is saying unknown flag of virtualmin and that the only place it is.
I hope you understood that :slight_smile:
this may show you what I mean
image

P.S. looks like the editor on here shows no difference, the screenshot does.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.