user email disabled but still receives cron messages


I have a few user accounts where the primary email address enabled is set to “No”, but cron messages still go into the account, filling them with gigabytes of errors.

I assume the system is bypassing virtualmin’s configurations somehow.

Any idea how I can correct this?

CentOS Linux 5.6
Postfix version 2.3.3
Virtualmin 3.88


Whenever the Email feature is enabled, configuration is added into Postfix that tells it that the user is part of a given domain name.

Without that, a user can’t receive email by using user@domain.tld.

However, emails generated from cron aren’t sent to user@domain.tld, they’re sent directly to the user account which owns the cron job. Disabling the email feature for that user won’t prevent them from receiving those cron notices.

The best way to solve that would be:

  1. Setup that user so that all incoming email goes into /dev/null (or some similar destination)

  2. Setup cron so that emails aren’t sent if the user doesn’t want email from them

Andrey – sorry to be dense; where does the /dev/null go?

Any quick thoughts on a strategy to do this on a global level, instead of searching through all 50 users on the system to see which have email disabled?