user dkim-milter does not exist - Centos 6.6

Hi there,
I have a problem using dkim on my new fresh centos 6.6 installation. I use virtualmin/webmin and when i am going to “Email Messages” -> “DomainKeyIdentifiedMail” i try for the first time to save a dkim record, by changing the name to 2015 and checking “Signing of outgoing mail enabled?” to YES.
As I click the save button, I see the message I have below:
http://pastebin.com/xeX4QuZX

The user dkim-milter does not exist as I double-checked on my system by running “cat /etc/passwd”.
I reinstalled dkim-milter and I receive the same error. I have another server with same configuration and its worked there from the start. I am not able to reinstall the system.
dkim version is the “dkim-milter-2.8.3-8.el6.x86_64”

How can I fix this problem? I cant seem to find a similar problem on the net.

P.S. I also find out that I was unable to create a user via ssh terminal “test123” as I get:

adduser: cannot lock /etc/passwd; try again later.```

my permissions: 
-rw-r--r-- 1 root root 2871 Mar  6 06:39 /etc/passwd


Why this is happening?

Howdy,

Ah, that error you got adding a user might explain why the RPM was also unable to add the user.

What is the output of this command:

find /etc -name "*.lock"

Same problem with CentOS 6.6_64bit, DKIM don’t start!

Enabling DKIM filter at boot time .. .. done

Starting DKIM filter …
… start failed : Starting DomainKeys Identified Mail Milter (dkim-filter): runuser: user dkim-milter does not exist [FAILED]

DKIM setup failed!

Re-starting DNS server …
… done

Any ideea?

It found solution for the problem with “runuser: user dkim-milter does not exist”, who is interested, read here:

http://dan-blog.ro/forum/topic/virtualmin-dkim-runuser-user-dkim-milter-does-not-exist

Use the “Translate” option from the top-left corner of the page.