url to access preview website

The “preview webiste” under virtualmin, works only if an user is loggen in virtualmin. Is possibile to get a similar address without login? just to let user to see the temporary website?


To use the “Preview Website”, you’d have to login into Virtualmin.

However, an alternative method of accomplishing what you’re after would be to create an alias for your user.

Let’s say that your user’s domain is, well, “users_domain.com”.

Let’s also say that your server’s domain is “server_domain.com”.

If you want to see “users_domain.com” prior to moving the DNS to your server, what you can do is create a new Alias Server in Virtualmin – called something like users_domain.server_domain.com.

The idea is that it’s creating a sub-domain, using a domain name that already works on your server.

You can do that by choosing “users_domain.com” in drop-down list on the top-left of Virtualmin, then going into “Create Virtual Server”, and choosing “Alias Server”.

For new domains you create, you can have Virtualmin automatically generate alias domains like this by going into System Settings -> Server Templates -> Default -> Virtual Server Creation -> Automatically create alias domain.


ok, so i’ve tried this:
1- To enter in my virtualmin i use: https://r2222.company.com:10000, ok? so the url is r2222.company.com.
2- inside virtualmin i’ve created the domain: main_domain.com.
3- under the main_domain.com i created an alias domain as: test_alias.com, ok?

So now, how can i test if this work? i’d like to use it just to test website before change the DNS to server.


Well, I’m getting a little confused with the domain names you’re mentioning above, I’m not sure which you’re saying is which…

However – the goal is to take a domain that has DNS pointing to your server, and to create a subdomain with that which points to a Virtual Server that doesn’t have DNS pointing to your server yet.

Then, to test the website, you’d just open up your browser, and browse to the sub-domain.

So go to the Virtual Server without DNS pointing to it yet, and create a new Virtual Server alias – using a domain that does have DNS pointing to your server.


Sorry to reawaken this old chestnut again.

I have read all the posts about this topic but those I have understood and tried have not worked for me.

Andreychek’s method seems to be the best for me at this stage but I cannot get it to work. I have listed all the steps below in case I have missed something.

Using the same nomenclature above :-

I have a domain set up called “users_domain.com” for which DNS has not been set up.

I have another domain which is resolving and working called “server_domain.com”.

In VM I selected users_domain.com and clicked “Create Virtual Server” then “Alias of users_domain.com”.

In the “Domain name” box I entered “users_domain.server_domain.com” and of course the hit the create button. All seemed to be ok.

In Firefox I entered “www.users_domain.server_domain.com” but got a “can’t find the server at www.users_domain.server_domain.com” error.

I have checked the logs and can’t find an entry which coincides with that.

Have I misunderstood something or just thick ?

The reason I need this functionality is that I have to use an application (Actinic) to upload.

Thanks for reading.

CentOS Linux 5.5
Virtualmin version 3.79 Pro

If you log into your server using SSH, and run “host www.users_domain.server_domain.com”, do you get an IP address as a result? That should tell you whether it’s working at all… if it’s not working from there, we’ll need to figure some things out :slight_smile:


Thanks Andreychek

Yes, that works, I get :

www.users_domain.server_domain.com has address 123.456.789.123

Thanks for your help.

Hmmm! that sounded like the problem was solved. Sorry if that is the case. I still can’t view the site by going to www.users_domain.server_domain.com

Sorry abou that.

Perhaps I am looking in the wrong logs.

Where would I find log entries for this type of error?

Any clues anybody?

CentOS Linux 5.5 Virtualmin version 3.79 Pro

Thanks for reading.


Well, I think we’re reaching a point where it’s hard to guess at the problem without being able to run a few tests… is there any chance you could share the domain name of the alias that’s not working for you? That would allow us to run a few tests and figure out what’s going awry :slight_smile:



Thanks Eric,

I wondered what you could test that I couldn’t and realised that checking DNS would be a cool idea.

I did so and found that the secondary DNS was failing for users_domain.server_domain.com (is ok for server_domain.com).

I added an entry for users_domain.server_domain.com to the secondary DNS and it is now working.

That doesn’t make any sense but the problem with the test I set up has now gone away.

Now I will try it with the real domain that I need to move.

Many thanks for giving me the inspiration.

Sorry to post in this old topic but found it with google so maybe it’s not a bad idea…

First I want to thank the team for this great free tool, thumbs up :smiley:

I have a similar problem : with my old admin panel, for instance if I wanted to host some videos online without paying a domain name, I used to create a ‘website’ called ‘videos’ and have access to it through the url : http://my.serverurl.net/~videos

I can’t make something similar with virtualmin, maybe my problem is that I don’t have any paid url pointing to my server, I mean I can access with the url provided by the hosting company which is something like : http://ns12345.hostingcompany.net

So when I wan’t to connect to virtualmin as master admin the url is https://ns12345.hostingcompany.net:10000

When I do the alias server trick, then I try to connect to http://videos.ns12345.hostingcompany.net and it’s not working, but the funny thing is that the regular server url (ns12345.hostingcompany.net ) is now pointing to the virtual server path… so I don’t get it

Having a url like http://ns12345.ovh.net/~virtual_server_name is not possible?

@xurok: I’m making some assumptions here, might be wrong, might be pointers in the right direction. :slight_smile:

videos.ns12345.hostingcompany.net” probably does not work because the nameserver at your hosting company which serves “ns12345.hostingcompany.net” does not have it configured as a “wildcard domain”. Thus only “ns12345.hostingcompany.net” will work, but not “*.ns12345.hostingcompany.net”.

When you created the virtual server for “videos”, you probably set it up (intentionally or unwittingly) as default server for unknown host names. Thus it will also serve “ns12345.hostingcompany.net”, and not just the configured “videos…”.

What you intend to do should also be possible. Try creating a virtual server named “ns12345.ovh.net” and give it some dummy content. VMin will also create a DNS zone for it, which the “outside world” is not going to use though, but that should not matter. You could also turn off the “DNS Domain” feature for the VServer.

Then, simply create a subdirectory “~virtual_server_name” under the “public_html”, and put your content there. And there you are. :slight_smile:

If you wish to use some different directory structure, you can also use Apache Aliases, through the function Services -> Configure Website -> Aliases and Redirects, or with the upcoming version 3.82 of VMin (the current one has a bug there), through Server Configuration -> Website Redirects.

Also check the forum entries and issues of the last days, there has been quite some talk about Aliasing in Apache lately.

Thanks Locutus for your great reply.

I think you just gave me some good advices here !

At the end of my previous post when I said 'ns12345.ovh.net" I meant ‘ns12345.hostingcompany.net’ I didn’t wanted to make a ad for my hosting company, I hope it didn’t confused you.

So I understand you, I just need to manually create a subdirectory into public_html folder and put my content within it, this can be a solution.

I will also check for topics about aliasing in apache.

Again thank you Locutus for your help

You’re welcome. :slight_smile:

Yep, try the “create subdirectory” way first, that’s probably the easiest way to do it. You’ll only need Apache Aliases if you wish to set up a more fancy directory structure outside of public_html. (You can rename that directory in VMin too btw. if you don’t like the name.)

Also, no worries about “advertising” hosting companies, I don’t think anyone here will mind if you do so by mentioning their domain. :wink:ovh.net” is also much shorter to type than “hostingcompany.net”.