Urgent Postfix Issue

Suddenly without any changes made to the server, mail is being denied (Relay Access Denied) for incoming and out going. I then notice that all mail aliases are missing from each virtual server. The aliases are showing in postfix>mail aliases, but not in the individual accounts.

When I run a check from http://intodns.com it shows no PTR’s, but my provider assures me they are still in working order.

Any quick insights would be appreciated as this is a production server with over 500 broken mail boxes.

Operating system CentOS Linux 5.2
Webmin version 1.430
Virtualmin version 3.61 (Pro)

Well, first, I’d try restarting Postfix and Webmin.

When you do so, do you see any errors in /var/log/maillog?

Assuming that doesn’t resolve it, what I would do is file a request in the bug tracker, mark it private, and include as many details about the problem as you can, including:

  • Are you able to authenticate as an email user (ie, can you log into Usermin or using Outlook (or whatever) and check your email?)

  • What’s the hostname having trouble

  • The output of "wc -l /etc/postfix/virtual"

That would be a good start. But, someone may need to drop into your box and take a look if nothing in the above makes the problem obvious,

Thank you for your input.

No errors in maillog when restarting webmin or postfix.

Trying to send mail out through desktop email client give relay access denied.

wc -l /etc/postfix/virtual
2277 /etc/postfix/virtual

I will submit a private bug tracker per you suggestion.


I wanted to follow up with this thread to say the issue has been resolved. Jamie logged in and fixed it. Turns out somehow my main.cf file got truncated. The thought is I must have had a failed edit and didn’t realize it.

Thanks so much Jamie! And thank you Eric for your advice.