Upgrading to Pro error

I tried out GPL first, loved it and just pruchased Pro license.

Went to upgrade through virtulamin, put in correct serial and license key. Hit upgrade. got error

"Failed to upgrade to Virtualmin Pro : An error occurred connecting to the Virtualmin Pro server : Failed to lookup IP address for software.virtualmin.com"

Went to shell and

server1:~# host software.virtualmin.com software.virtualmin.com has address 70.86.4.226
software.virtualmin.com mail is handled by 5 mail.software.virtualmin.com.

What should I do now?

I found this post

http://www.virtualmin.com/index.php?option=com_fireboard&Itemid=77&func=view&id=8144&catid=8#8144

I suppose my dns is working OK, I can get lookups from command line, etc.

Nothing has been installed on server except for virtualmin gpl and ssh server and a few sites. No firewall that I know of.

server1:~# dig software.virtualmin.com

; <<>> DiG 9.3.4 <<>> software.virtualmin.com
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 55817
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 2

;; QUESTION SECTION:
;software.virtualmin.com. IN A

;; ANSWER SECTION:
software.virtualmin.com. 37802 IN A 70.86.4.226

;; AUTHORITY SECTION:
software.virtualmin.com. 37802 IN NS www.virtualmin.com.
software.virtualmin.com. 37802 IN NS swelltech.com.

;; ADDITIONAL SECTION:
www.virtualmin.com. 37802 IN A 70.86.4.238
swelltech.com. 37802 IN A 208.113.149.117

;; Query time: 1 msec
;; SERVER: 64.34.160.76#53(64.34.160.76)
;; WHEN: Fri Feb 15 16:24:22 2008
;; MSG SIZE rcvd: 131

nevermind, I just put it in etc/hosts and did it

Without address in hosts though it still doesn’t work and don’t know why