Upgrading MySQL version 5.1.73 to MySQL version 5.5.x ??

Dear all.
Currently I am running here at the office a CentOS 6.5 box with webmin/virtualmin with 2 php versions. The one which comes standart and V 5.4.16. Up until now everything worked fin. I got an email that there was an upgrade for phpmyadmin and now i can not connect with my phpmyadmin
Now it says phpMyAdmin - Error
You should upgrade to MySQL 5.5.0 or later.
Currently I have running the version which comes with the installation which is: MySQL version 5.1.73
Is there a way how to upgrade the MySQL without damaging the current created databases with all the tables?

Can anyone help me out with this, plz?
Hoping to hear from you.


There are some details on that issue here:


I would not recommend upgrading MySQL though, I would suggest downgrading the phpMyAdmin version.


Dear Andreychek.
Many thanks for your quick reply.
Based on this: http://www.phpmyadmin.net/documentation/changelog.php
i see that it the lastest relase is of 3 days ago.
It is a quite shame that there are no warnings for these kinda upgrades.
Now I have these questions:

  1. Can you indicate if there is an entry in this forum explaining how to downgrade a phpmyadmin version? Must confess that I have never donde this before.
  2. Will it become available in the near future so i can safely upgrade the phpmyadmin and the MySQL?
    Hoping to hear from you again.
    – Paco


Normally, an Install Script with a dependency that’s incompatible with your system (such as MySQL 5.5) shouldn’t show up as something you can install.

The fact that it did is a bug, as described in the other post I linked to.

To install an older version of phpMyAmin, you would need to uninstall what you have installed now, then reinstall a compatible version.

There isn’t a supported way to upgrade MySQL to a newer version. Virtualmin uses the MySQL version included with your distribution – and RHEL/CentOS 6 provides MySQL 5.1.x.

RHEL/CentOS 7 will be coming out shortly, probably within a few months. That will include a more recent MySQL version. Until then, there won’t be a supported way to use phpMyAdmin versions that require MySQL 5.5 on CentOS.