upgrading from 3.83 to 3.84

I have an installation of virtualmin on a VPS host. I’m about to install a fresh virtualmin on a new dedicated server. I would like both to be the same version in order to facilitate moving all the domains over (using the backup system). Well, the original system is version 3.83 with only 4 new virtualmin packages available for installation. The installation script available for download says it’s version 3.84 however. I’m not sure why the original system isn’t picking up that there is a version upgrade available?

Only 1 minor version difference probably doesn’t matter for my purposes, but I am curious to know why the old one doesn’t know that there is a newer version available (yes, I clicked the “Refresh All Packages” button :slight_smile:



Which Linux distribution are you using on those two servers?


64 bit CentOS Linux 5.5 on the old, and 64 bit CentOS Linux 5.? on the new (new isn’t setup yet so I’m guessing latest CentOS, but not sure yet).

Well, there’s a problem with the CentOS 5 GPL repository at the moment that’s causing 3.84 to not be available. It should work on other distros though. It’ll also be fixed up soon.

Is it possible that the server that has 3.84 isn’t actually CentOS?


centos works now. Nice!

The 3.84 was the downloadable installation script version, not anything seen from within CentOS.

I see the upgrade is now available on the old system. Problem solved :slight_smile: